aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbset
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-01-05 00:22:24 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-05 00:22:24 +0000
commitfc80135c474ac0cff15366721cefea7e44b26932 (patch)
treeab93bd47f05d0b56e56519b5480b92d676bc0a0f /packages/fbset
parent002d5e8eff67e411023da9e63097eafead448330 (diff)
downloadopenembedded-fc80135c474ac0cff15366721cefea7e44b26932.tar.gz
fbset: stop making my eyes bleed with '############' and use the update-alternatives bbclass to update the alternatives
~lart coredump and his templates
Diffstat (limited to 'packages/fbset')
-rw-r--r--packages/fbset/fbset_2.1.bb37
1 files changed, 12 insertions, 25 deletions
diff --git a/packages/fbset/fbset_2.1.bb b/packages/fbset/fbset_2.1.bb
index 28161f7636..ab505110e4 100644
--- a/packages/fbset/fbset_2.1.bb
+++ b/packages/fbset/fbset_2.1.bb
@@ -6,40 +6,27 @@
# Date: 28-May-06
DESCRIPTION = "The fbset console tool"
-HOMEPAGE = ""
LICENSE = "GPL"
-######################################################################################
+PR = "r2"
SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
- file://makefile.patch;patch=1"
+ file://makefile.patch;patch=1"
-######################################################################################
+inherit autotools update-alternatives
-PR = "r1"
-PARALLEL_MAKE=""
-
-######################################################################################
-
-inherit autotools
-
-######################################################################################
+PARALLEL_MAKE = ""
do_install() {
- install -d ${D}/usr/sbin ${D}/usr/share/man/man8 ${D}/usr/share/man/man5
-
- install -m 0755 ${WORKDIR}/${P}/fbset ${D}/usr/sbin/fbset.real
-
- install -m 0644 ${WORKDIR}/${P}/*.5 ${D}/usr/share/man/man5
- install -m 0644 ${WORKDIR}/${P}/*.8 ${D}/usr/share/man/man8
+ install -d ${D}/usr/sbin ${D}/usr/share/man/man8 ${D}/usr/share/man/man5
+ install -m 0755 ${WORKDIR}/${P}/fbset ${D}/usr/sbin/fbset.real
+ install -m 0644 ${WORKDIR}/${P}/*.5 ${D}/usr/share/man/man5
+ install -m 0644 ${WORKDIR}/${P}/*.8 ${D}/usr/share/man/man8
}
-######################################################################################
+ALTERNATIVE_NAME = "fbset"
+ALTERNATIVE_LINK = "${sbindir}/${ALTERNATIVE_NAME}"
+ALTERNATIVE_PATH = "${sbindir}/fbset.real"
+ALTERNATIVE_PRIORITY = "55"
-pkg_postinst_${PN}() {
- update-alternatives --install /usr/sbin/fbset fbset /usr/sbin/fbset.real 55
-}
-pkg_postrm_${PN}() {
- update-alternatives --remove fbset /usr/sbin/fbset.real
-}