aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbvncserver
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-05 09:19:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 09:19:17 +0000
commit1a4074a52600e3393f57a2e674a84db3309909a7 (patch)
treebca8c958f6902e670c4cb220d9c72df234ff520d /packages/fbvncserver
parenta4589d14559dd4b8f7ef93810549e12d1ee24d75 (diff)
downloadopenembedded-1a4074a52600e3393f57a2e674a84db3309909a7.tar.gz
add fbvncserver patch from Henry von Tresckow - fixes bug #202
Diffstat (limited to 'packages/fbvncserver')
-rw-r--r--packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb16
-rw-r--r--packages/fbvncserver/fbvncserver_0.9.4.bb29
-rw-r--r--packages/fbvncserver/files/zaurus_panel.jpgbin35547 -> 0 bytes
3 files changed, 32 insertions, 13 deletions
diff --git a/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb b/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
index 39004cbb7b..44bdd9b04f 100644
--- a/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
+++ b/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
@@ -1,19 +1,25 @@
-DESCRIPTION = "framebuffer VNC server keyboard events module"
-SECTION = "kernel"
+DESCRIPTION = "Framebuffer VNC server keyboard events module"
+SECTION = "kernel/module"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://sdgsystems.com/download/fbvncserver-${PV}.tar.gz \
file://libvncs0.6.patch;patch=1 \
file://paths.patch;patch=1 \
- file://kernelinclude.patch;patch=1"
+ file://kernelinclude.patch;patch=1 \
+ file://ipaq.patch;patch=1"
S = "${WORKDIR}/fbvncserver-${PV}"
inherit module
-EXTRA_OEMAKE = "KERNEL_INCLUDES=-I${STAGING_KERNEL_DIR}/include zaurus_kbdsim.o"
+FBVNCSERVER_SYSTEM = "zaurus"
+FBVNCSERVER_SYSTEM_h3600 = "ipaq"
+FBVNCSERVER_SYSTEM_h3900 = "ipaq"
+
+EXTRA_OEMAKE = "KERNEL_INCLUDES=-I${STAGING_KERNEL_DIR}/include ${FBVNCSERVER_SYSTEM}_kbdsim.o"
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc
- install -m 0644 zaurus_kbdsim.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc/
+ install -m 0644 ${FBVNCSERVER_SYSTEM}_kbdsim.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc/kbdsim.o
}
diff --git a/packages/fbvncserver/fbvncserver_0.9.4.bb b/packages/fbvncserver/fbvncserver_0.9.4.bb
index fd2a1e6138..66b7349df7 100644
--- a/packages/fbvncserver/fbvncserver_0.9.4.bb
+++ b/packages/fbvncserver/fbvncserver_0.9.4.bb
@@ -1,18 +1,24 @@
-DESCRIPTION = "framebuffer VNC server"
+DESCRIPTION = "Framebuffer VNC server"
LICENSE = "GPL"
SECTION = "console/utils"
-DEPENDS = "libvncserver jpeg zlib"
+#DEPENDS = "libvncserver jpeg zlib"
+# using older version due of error with libvncserver-0.7.1
+# fbvncserver.c:577: error: structure has no member named `rfbAlwaysShared'
+# fbvncserver.c:602: error: structure has no member named `rfbClientHead'
+DEPENDS = "libvncserver-0.6 jpeg zlib"
RDEPENDS = "fbvncserver-kmodule libvncserver-storepasswd libvncserver-javaapplet"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://sdgsystems.com/download/fbvncserver-${PV}.tar.gz \
file://libvncs0.6.patch;patch=1 \
file://paths.patch;patch=1 \
file://kernelinclude.patch;patch=1 \
file://buildfix.patch;patch=1 \
- file://zaurus_panel.jpg \
+ file://ipaq.patch;patch=1 \
file://init"
+S = "${WORKDIR}/fbvncserver-${PV}"
+
export INCLUDES = "-I${STAGING_INCDIR}"
export LIBS = "-L${STAGING_LIBDIR} -lpthread"
@@ -25,18 +31,25 @@ inherit update-rc.d
INITSCRIPT_NAME = "fbvncinput"
INITSCRIPT_PARAMS = "defaults 97"
+FBVNCSERVER_SYSTEM = "zaurus"
+FBVNCSERVER_SYSTEM_h3600 = "ipaq"
+FBVNCSERVER_SYSTEM_h3900 = "ipaq"
+
do_compile () {
- oe_runmake zaurus_fbvncserver zaurus_tssimd
+ oe_runmake ${FBVNCSERVER_SYSTEM}_fbvncserver ${FBVNCSERVER_SYSTEM}_tssimd
}
do_install () {
install -d ${D}${bindir}
- install -m 0755 zaurus_fbvncserver ${D}${bindir}/fbvncserver
- install -m 0755 zaurus_tssimd ${D}${bindir}/tssimd
+ install -m 0755 ${FBVNCSERVER_SYSTEM}_fbvncserver ${D}${bindir}/fbvncserver
+ install -m 0755 ${FBVNCSERVER_SYSTEM}_tssimd ${D}${bindir}/tssimd
install -d ${D}${datadir}/fbvncserver
- install -m 0644 ${WORKDIR}/zaurus_panel.jpg ${D}${datadir}/fbvncserver/
+ install -m 0644 ${FBVNCSERVER_SYSTEM}_panel.jpg ${D}${datadir}/fbvncserver/
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/fbvncinput
}
+
+FILES_${PN} += " /usr/share/fbvncserver/*.jpg"
+
diff --git a/packages/fbvncserver/files/zaurus_panel.jpg b/packages/fbvncserver/files/zaurus_panel.jpg
deleted file mode 100644
index cb8543f1db..0000000000
--- a/packages/fbvncserver/files/zaurus_panel.jpg
+++ /dev/null
Binary files differ