aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbvncserver
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/fbvncserver
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/fbvncserver')
-rw-r--r--packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb19
-rw-r--r--packages/fbvncserver/fbvncserver_0.9.4.bb10
2 files changed, 24 insertions, 5 deletions
diff --git a/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb b/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
index e69de29bb2..e5cbd0a5fb 100644
--- a/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
+++ b/packages/fbvncserver/fbvncserver-kmodule_0.9.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "framebuffer VNC server keyboard events module"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+SRC_URI = "http://sdgsystems.com/download/fbvncserver-${PV}.tar.gz \
+ file://libvncs0.6.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://kernelinclude.patch;patch=1"
+
+S = "${WORKDIR}/fbvncserver-${PV}"
+
+inherit module
+
+EXTRA_OEMAKE = "KERNEL_INCLUDES=-I${STAGING_KERNEL_DIR}/include zaurus_kbdsim.o"
+
+do_install () {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc
+ install -m 0644 zaurus_kbdsim.o ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc/
+}
diff --git a/packages/fbvncserver/fbvncserver_0.9.4.bb b/packages/fbvncserver/fbvncserver_0.9.4.bb
index 7fe905c95c..cdff17efa4 100644
--- a/packages/fbvncserver/fbvncserver_0.9.4.bb
+++ b/packages/fbvncserver/fbvncserver_0.9.4.bb
@@ -29,12 +29,12 @@ do_compile () {
}
do_install () {
- install -d ${D}/usr/bin
- install -m 0755 zaurus_fbvncserver ${D}/usr/bin/fbvncserver
- install -m 0755 zaurus_tssimd ${D}/usr/bin/tssimd
+ install -d ${D}${bindir}
+ install -m 0755 zaurus_fbvncserver ${D}${bindir}/fbvncserver
+ install -m 0755 zaurus_tssimd ${D}${bindir}/tssimd
- install -d ${D}/usr/share/fbvncserver
- install -m 0644 ${WORKDIR}/zaurus_panel.jpg ${D}/usr/share/fbvncserver/
+ install -d ${D}${datadir}/fbvncserver
+ install -m 0644 ${WORKDIR}/zaurus_panel.jpg ${D}${datadir}/fbvncserver/
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/fbvncinput