aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ffmpeg
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-10 12:21:55 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-10 12:21:55 +0000
commit25591e058ffbedf613b51c8c95efeac29d5ce99e (patch)
tree233a7568acf8b3fd4c09d1a0939570db35150ce2 /packages/ffmpeg
parentec9b38a8bc554452f2c0fafc83d1e6540e514713 (diff)
downloadopenembedded-25591e058ffbedf613b51c8c95efeac29d5ce99e.tar.gz
ffmpeg: drop CVS, add SVN - close #1125
Diffstat (limited to 'packages/ffmpeg')
-rw-r--r--packages/ffmpeg/ffmpeg_cvs.bb84
-rw-r--r--packages/ffmpeg/ffmpeg_svn.bb127
2 files changed, 127 insertions, 84 deletions
diff --git a/packages/ffmpeg/ffmpeg_cvs.bb b/packages/ffmpeg/ffmpeg_cvs.bb
deleted file mode 100644
index bfd68eb3e2..0000000000
--- a/packages/ffmpeg/ffmpeg_cvs.bb
+++ /dev/null
@@ -1,84 +0,0 @@
-#Remove the dash after cvs below when 0.4.9 changes in PV
-PV = "0.4.9-pre1+cvs-${SRCDATE}"
-DESCRIPTION = "ffmpeg"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "zlib libvorbis faac liba52 lame"
-LICENSE = "GPL"
-PR = "r1"
-S = "${WORKDIR}/ffmpeg"
-DEFAULT_PREFERENCE = "-1"
-
-inherit autotools
-
-SRC_URI = "cvs://anonymous@mplayerhq.hu/cvsroot/ffmpeg;module=ffmpeg \
- file://configure.patch;patch=0 \
- file://common.patch;patch=1 \
- file://soname.patch;patch=1 \
- "
-
-TARGET_LDFLAGS_append = " -lm -la52 "
-
-EXTRA_OECONF=" \
- --enable-mp3lame \
- --enable-vorbis \
- --enable-faac \
- --enable-a52 \
- --enable-a52bin \
- --enable-pp \
-# --enable-shared-pp \
- --enable-shared \
- --disable-amr_nb \
- --enable-amr_nb-fixed \
- --disable-amr_wb \
- --enable-pthreads \
- --enable-gpl \
- --enable-zlib \
- \
- --disable-audio-beos \
- --disable-v4l \
- --disable-dv1394 \
- --disable-debug \
- --disable-ffserver \
- --disable-ffplay \
- \
- --cross-prefix=${TARGET_PREFIX} \
- --extra-cflags=\$(TARGET_CFLAGS) \
- --extra-ldflags=\$(TARGET_LDFLAGS) \
- --extra-libs=\$(TARGET_LDFLAGS) \
- \
- --cpu=${PACKAGE_ARCH} \
- --prefix=${D}${prefix} \
- --mandir=${D}${prefix}/share/man \
-"
-
-PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
-FILES_${PN} = "${bindir}"
-FILES_${PN}-dev = "${includedir}"
-FILES_libavcodec = "${libdir}/libavcodec*.so.*"
-FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
-FILES_libavformat = "${libdir}/libavformat*.so.*"
-FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
-
-# We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
-
-
-do_configure_prepend() {
- export CC="${CC}"
-}
-
-do_stage() {
- oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
- oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ffmpeg
- install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
- install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
- install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
- install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
- install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
- install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
- install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
- install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
-}
diff --git a/packages/ffmpeg/ffmpeg_svn.bb b/packages/ffmpeg/ffmpeg_svn.bb
new file mode 100644
index 0000000000..4098d721f9
--- /dev/null
+++ b/packages/ffmpeg/ffmpeg_svn.bb
@@ -0,0 +1,127 @@
+DESCRIPTION = "ffmpeg"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "zlib libvorbis faac liba52 lame"
+PV = "0.4.9+svn${SRCDATE}"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.mplayerhq.hu/ffmpeg/;module=trunk"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+TARGET_LDFLAGS_append = " -lm -la52 "
+
+EXTRA_OECONF = " \
+ --enable-mp3lame \
+ --enable-vorbis \
+ --enable-faad \
+ --enable-a52 \
+ --enable-a52bin \
+ --enable-pp \
+ --enable-shared \
+ --enable-pthreads \
+ --enable-gpl \
+ \
+ --disable-audio-beos \
+ --disable-v4l \
+ --disable-dv1394 \
+ --disable-debug \
+ --disable-ffserver \
+ --disable-ffplay \
+ \
+ --cross-prefix=${TARGET_PREFIX} \
+ \
+ --cpu=${PACKAGE_ARCH} \
+"
+
+
+# We do this because the install program is called with -s
+# which causes it to call "strip" and it then mangles cross compiled stuff..
+PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
+
+do_configure_prepend() {
+ export CC="${CC}"
+}
+
+oe_runconf () {
+ if [ -x ${S}/configure ] ; then
+ cfgcmd="${S}/configure \
+ --prefix=${prefix} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@"
+ oenote "Running $cfgcmd..."
+ $cfgcmd || oefatal "oe_runconf failed"
+ else
+ oefatal "no configure script found"
+ fi
+
+}
+
+do_stage() {
+ oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavutil libavutil ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libpostproc libpostproc ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ffmpeg
+ install -m 0644 ${S}/libavcodec/avcodec.h \
+ ${STAGING_INCDIR}/ffmpeg/avcodec.h
+
+ install -m 0644 ${S}/libavformat/avformat.h \
+ ${STAGING_INCDIR}/ffmpeg/avformat.h
+ install -m 0644 ${S}/libavformat/avio.h \
+ ${STAGING_INCDIR}/ffmpeg/avio.h
+ install -m 0644 ${S}/libavformat/rtp.h \
+ ${STAGING_INCDIR}/ffmpeg/rtp.h
+ install -m 0644 ${S}/libavformat/rtsp.h \
+ ${STAGING_INCDIR}/ffmpeg/rtsp.h
+ install -m 0644 ${S}/libavformat/rtspcodes.h \
+ ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
+
+ install -m 0644 ${S}/libavutil/avutil.h \
+ ${STAGING_INCDIR}/ffmpeg/avutil.h
+ install -m 0644 ${S}/libavutil/bswap.h \
+ ${STAGING_INCDIR}/ffmpeg/bswap.h
+ install -m 0644 ${S}/libavutil/common.h \
+ ${STAGING_INCDIR}/ffmpeg/common.h
+ install -m 0644 ${S}/libavutil/crc.h \
+ ${STAGING_INCDIR}/ffmpeg/crc.h
+ install -m 0644 ${S}/libavutil/integer.h \
+ ${STAGING_INCDIR}/ffmpeg/integer.h
+ install -m 0644 ${S}/libavutil/intfloat_readwrite.h \
+ ${STAGING_INCDIR}/ffmpeg/intfloat_readwrite.h
+ install -m 0644 ${S}/libavutil/mathematics.h \
+ ${STAGING_INCDIR}/ffmpeg/mathematics.h
+ install -m 0644 ${S}/libavutil/rational.h \
+ ${STAGING_INCDIR}/ffmpeg/rational.h
+}
+
+PACKAGES += "libavcodec libavcodec-dev \
+ libavformat libavformat-dev \
+ libavutil libavutil-dev \
+ libpostproc libpostproc-dev"
+
+FILES_${PN} = "${bindir}"
+FILES_${PN}-dev = "${includedir}"
+FILES_${PN}-doc = "${mandir}"
+
+FILES_libavcodec = "${libdir}/libavcodec*.so.*"
+FILES_libavcodec-dev = "${libdir}/libavcodec*.so \
+ ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
+
+FILES_libavformat = "${libdir}/libavformat*.so.*"
+FILES_libavformat-dev = "${libdir}/libavformat*.so \
+ ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
+
+FILES_libavutil = "${libdir}/libavutil*.so.*"
+FILES_libavutil-dev = "${libdir}/libavutil*.so \
+ ${libdir}/libavutil*.la ${libdir}/libavutil*.a"
+
+FILES_libpostproc = "${libdir}/libpostproc*.so.*"
+FILES_libpostproc-dev = "${libdir}/libpostproc*.so \
+ ${libdir}/libpostproc*.la ${libdir}/libpostproc*.a"