aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ffmpeg
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2004-12-24 23:16:08 +0000
committerRene Wagner <rw@handhelds.org>2004-12-24 23:16:08 +0000
commit015a705b9ccaaf789f994f4188debe34498a7900 (patch)
tree6dfe9215697c1cd3cdc64082ac9ece024a13b1d0 /packages/ffmpeg
parent9d76d25d6b2e00df671827e97c2faf6444927da2 (diff)
downloadopenembedded-015a705b9ccaaf789f994f4188debe34498a7900.tar.gz
ffmpeg: add missing patch
BKrev: 41cca33821uxvQPCxwr96ra3_aDd1g
Diffstat (limited to 'packages/ffmpeg')
-rw-r--r--packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch0
-rw-r--r--packages/ffmpeg/ffmpeg_0.4.9-pre1.bb87
2 files changed, 87 insertions, 0 deletions
diff --git a/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch b/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch
diff --git a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
index e69de29bb2..fd693988b2 100644
--- a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
+++ b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
@@ -0,0 +1,87 @@
+
+DESCRIPTION = "ffmpeg"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libvorbis faad2 faac liba52 lame mplayer"
+LICENSE = "LGPL"
+
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
+ file://configure.patch;patch=0 \
+ file://common.patch;patch=1 \
+ "
+
+TARGET_LDFLAGS_append = " -lm -la52 "
+
+EXTRA_OECONF=" \
+ --enable-mp3lame \
+ --enable-vorbis \
+ --enable-faad \
+ --enable-faadbin \
+ --enable-faac \
+ --enable-a52 \
+ --enable-a52bin \
+ --enable-pp \
+ --enable-shared-pp \
+ --enable-shared \
+ --disable-amr_nb \
+ --enable-amr_nb-fixed \
+ --disable-amr_wb \
+ --enable-pthreads \
+ --enable-gpl \
+ --enable-zlib \
+ \
+ --disable-audio-beos \
+ --disable-v4l \
+ --disable-dv1394 \
+ --disable-debug \
+ --disable-ffserver \
+ --disable-ffplay \
+ \
+ --cross-prefix=${TARGET_PREFIX} \
+ --extra-cflags=\$(TARGET_CFLAGS) \
+ --extra-ldflags=\$(TARGET_LDFLAGS) \
+ --extra-libs=\$(TARGET_LDFLAGS) \
+ \
+ --cpu=${PACKAGE_ARCH} \
+ --prefix=${D}/usr \
+"
+
+# We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
+PATH_prepend=${CROSS_DIR}/${TARGET_SYS}/bin:
+
+# --enable-shared-pp \
+
+do_configure_prepend() {
+ export CC="${CC}"
+}
+
+do_install_append() {
+ # Need to fix up the shared libraries
+ cd ${D}/usr/lib
+
+ mv libavcodec-${PV}.so libavcodec.so.0.0.0
+ ln -s libavcodec.so.0.0.0 libavcodec-${PV}.so
+ ln -s libavcodec.so.0.0.0 libavcodec.so.0
+
+ mv libavformat-${PV}.so libavformat.so.0.0.0
+ ln -s libavformat.so.0.0.0 libavformat-${PV}.so
+ ln -s libavformat.so.0.0.0 libavformat.so.0
+}
+
+do_stage() {
+ oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ffmpeg
+ install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
+ install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
+ install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
+ install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
+ install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
+ install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
+ install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
+ install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
+}