aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ffmpeg
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/ffmpeg
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/ffmpeg')
-rw-r--r--packages/ffmpeg/ffmpeg_0.4.9-pre1.bb2
-rw-r--r--packages/ffmpeg/ffmpeg_cvs.bb83
2 files changed, 84 insertions, 1 deletions
diff --git a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
index 6770703b8a..233be09722 100644
--- a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
+++ b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
@@ -48,7 +48,7 @@ EXTRA_OECONF=" \
--extra-libs=\$(TARGET_LDFLAGS) \
\
--cpu=${PACKAGE_ARCH} \
- --prefix=${D}/${prefix} \
+ --prefix=${D}${prefix} \
"
PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
diff --git a/packages/ffmpeg/ffmpeg_cvs.bb b/packages/ffmpeg/ffmpeg_cvs.bb
index e69de29bb2..40ee8d937f 100644
--- a/packages/ffmpeg/ffmpeg_cvs.bb
+++ b/packages/ffmpeg/ffmpeg_cvs.bb
@@ -0,0 +1,83 @@
+PV = "0.4.9-pre1+cvs-${CVSDATE}"
+DESCRIPTION = "ffmpeg"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libvorbis faac liba52 lame"
+LICENSE = "GPL"
+PR = "r1"
+S = ${WORKDIR}/ffmpeg
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+SRC_URI = "cvs://anonymous@mplayerhq.hu/cvsroot/ffmpeg;module=ffmpeg \
+ file://configure.patch;patch=0 \
+ file://common.patch;patch=1 \
+ file://soname.patch;patch=1 \
+ "
+
+TARGET_LDFLAGS_append = " -lm -la52 "
+
+EXTRA_OECONF=" \
+ --enable-mp3lame \
+ --enable-vorbis \
+ --enable-faac \
+ --enable-a52 \
+ --enable-a52bin \
+ --enable-pp \
+# --enable-shared-pp \
+ --enable-shared \
+ --disable-amr_nb \
+ --enable-amr_nb-fixed \
+ --disable-amr_wb \
+ --enable-pthreads \
+ --enable-gpl \
+ --enable-zlib \
+ \
+ --disable-audio-beos \
+ --disable-v4l \
+ --disable-dv1394 \
+ --disable-debug \
+ --disable-ffserver \
+ --disable-ffplay \
+ \
+ --cross-prefix=${TARGET_PREFIX} \
+ --extra-cflags=\$(TARGET_CFLAGS) \
+ --extra-ldflags=\$(TARGET_LDFLAGS) \
+ --extra-libs=\$(TARGET_LDFLAGS) \
+ \
+ --cpu=${PACKAGE_ARCH} \
+ --prefix=${D}${prefix} \
+ --mandir=${D}${prefix}/man \
+"
+
+PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
+FILES_${PN} = "${bindir}"
+FILES_${PN}-dev = "${includedir}"
+FILES_libavcodec = "${libdir}/libavcodec*.so.*"
+FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
+FILES_libavformat = "${libdir}/libavformat*.so.*"
+FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
+
+# We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
+PATH_prepend=${CROSS_DIR}/${TARGET_SYS}/bin:
+
+
+do_configure_prepend() {
+ export CC="${CC}"
+}
+
+do_stage() {
+ oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ffmpeg
+ install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
+ install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
+ install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
+ install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
+ install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
+ install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
+ install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
+ install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
+}