aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fftw
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-11 12:34:42 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-11 12:34:42 +0000
commitf91cc88da285f871bdbbfb2b332a9b16195c5496 (patch)
tree92beb3ed68941e6278970e436e41784481c6c92e /packages/fftw
parentecfef382035fc2da121c6af6a9f99f3002069867 (diff)
downloadopenembedded-f91cc88da285f871bdbbfb2b332a9b16195c5496.tar.gz
benchfft: fixup Makefile so compile gets a bit further. Still tries to run generated binaries, though
Diffstat (limited to 'packages/fftw')
-rw-r--r--packages/fftw/benchfft_3.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/fftw/benchfft_3.1.bb b/packages/fftw/benchfft_3.1.bb
index 8d2d8b7f34..7b9a7110cf 100644
--- a/packages/fftw/benchfft_3.1.bb
+++ b/packages/fftw/benchfft_3.1.bb
@@ -3,12 +3,19 @@ SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPLv2"
+# single precision fftw is called fftwf
+DEPENDS = "fftwf"
+
SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz"
EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
inherit autotools pkgconfig
+do_compile_prepend() {
+ sed -i -e 's:all-recursive:$(RECURSIVE_TARGETS):g' ${S}/Makefile
+}
+
do_stage () {
autotools_stage_all
}