aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fltk
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-20 21:56:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-20 21:56:12 +0000
commit0b0038780ce149f018f511a7adfd4d0773ab9a5d (patch)
tree1cbaad2f722dec268f8f881be5f2f192019c91a2 /packages/fltk
parent9c144f0bf3404b31709b8756b61d80a4453e3369 (diff)
downloadopenembedded-0b0038780ce149f018f511a7adfd4d0773ab9a5d.tar.gz
add efltk, the enhanced FLTK
Diffstat (limited to 'packages/fltk')
-rw-r--r--packages/fltk/efltk_2.0.7.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/fltk/efltk_2.0.7.bb b/packages/fltk/efltk_2.0.7.bb
new file mode 100644
index 0000000000..57737e1c57
--- /dev/null
+++ b/packages/fltk/efltk_2.0.7.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "EFLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://equinox-project.org/page/documentation"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "zlib jpeg libpng libxext libxft"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ede/efltk-${PV}.tar.gz"
+S = "${WORKDIR}/efltk"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "\
+ --enable-shared \
+ --enable-xdbe \
+ --enable-xft \
+ --enable-gl \
+ --disable-mysql \
+ --disable-unixODBC \
+ --x-includes=${STAGING_INCDIR}/freetype2 \
+ --x-libraries=${STAGING_LIBDIR} \
+"
+
+# yes, this is nasty, but configure is so broken there is no other way
+do_configure() {
+ gnu-configize
+ oe_runconf
+ mv -f config.h save
+ autotools_do_configure
+ mv -f save config.h
+}
+
+# more nasties
+do_configure_append() {
+ sed -i s,/usr/include,${STAGING_INCDIR}, makeinclude
+ sed -i s,/usr/include/freetype2,, makeinclude
+ sed -i s,/usr/bin/strip,echo, makeinclude
+ sed -i s,CONFIGDIR,'"${datadir}/ede/"', src/core/Fl_Config.cpp
+}
+
+do_stage() {
+ oe_runmake install prefix="${STAGING_DIR}" \
+ bindir="${STAGING_BINDIR}" \
+ includedir="${STAGING_INCDIR}" \
+ libdir="${STAGING_LIBDIR}" \
+ datadir="${STAGING_DATADIR}"
+}
+
+do_install () {
+ install -d ${D}${libdir}
+ oe_runmake install prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ datadir="${STAGING_DATADIR}"
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libefltk${PV}', d)
+}
+
+LEAD_SONAME = "libefltk.so"
+
+FILES_${PN} += "${libdir}/fltk/*.theme"
+FILES_${PN}-dbg += "${libdir}/fltk/.debug"