aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fltk
diff options
context:
space:
mode:
authorJoaquim Duran <joaquinduran@adtelecom.es>2006-10-12 15:43:41 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-12 15:43:41 +0000
commit53a328a3067ad0b48070a3a9f2b25990653867d7 (patch)
tree2ddabd4c034f937b12c09b43321003c2e18d5734 /packages/fltk
parent8597287146730cbaf6e26796c6746fcc294c0216 (diff)
downloadopenembedded-53a328a3067ad0b48070a3a9f2b25990653867d7.tar.gz
fltk: added 1.1.7 - close #1459
Diffstat (limited to 'packages/fltk')
-rw-r--r--packages/fltk/fltk_1.1.7.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/fltk/fltk_1.1.7.bb b/packages/fltk/fltk_1.1.7.bb
new file mode 100644
index 0000000000..10b68ef017
--- /dev/null
+++ b/packages/fltk/fltk_1.1.7.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "jpeg libpng zlib"
+
+SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2"
+
+S = "${WORKDIR}/fltk-${PV}"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--enable-shared --disable-gl --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
+}
+
+LEAD_SONAME = "libfltk.so"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += " ${bindir}/fltk-config"