aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fltk
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-06-06 14:38:01 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-06-06 14:38:01 +0000
commita7078c7115a562d138da6498119e27b143e12810 (patch)
tree0e693943501cf2089d4ed7c1dd0b6dac4ba36b52 /packages/fltk
parent923c2692e9bfc580eee2a564d5ef8824080f71fa (diff)
downloadopenembedded-a7078c7115a562d138da6498119e27b143e12810.tar.gz
fltk: update to 1.1.9 and make it build again
* make fltk build again * disable test-dir for now and until we fixed that fluid is build natvie * commit makes bug 430 invalid
Diffstat (limited to 'packages/fltk')
-rw-r--r--packages/fltk/files/.mtn2git_empty0
-rw-r--r--packages/fltk/files/disable_test.patch13
-rw-r--r--packages/fltk/fltk_1.1.9.bb35
3 files changed, 48 insertions, 0 deletions
diff --git a/packages/fltk/files/.mtn2git_empty b/packages/fltk/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fltk/files/.mtn2git_empty
diff --git a/packages/fltk/files/disable_test.patch b/packages/fltk/files/disable_test.patch
new file mode 100644
index 0000000000..8c01a1f806
--- /dev/null
+++ b/packages/fltk/files/disable_test.patch
@@ -0,0 +1,13 @@
+Index: fltk-1.1.9/Makefile
+===================================================================
+--- fltk-1.1.9.orig/Makefile 2008-06-06 16:14:11.936736201 +0200
++++ fltk-1.1.9/Makefile 2008-06-06 16:14:22.526357637 +0200
+@@ -27,7 +27,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) src fluid test documentation
++DIRS = $(IMAGEDIRS) src fluid documentation
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/packages/fltk/fltk_1.1.9.bb b/packages/fltk/fltk_1.1.9.bb
new file mode 100644
index 0000000000..a2c5dcb5ab
--- /dev/null
+++ b/packages/fltk/fltk_1.1.9.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
+ file://disable_test.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/fltk-${PV}"
+
+inherit lib_package autotools binconfig
+
+EXTRA_OECONF = "--enable-shared \
+ --enable-threads \
+ --enable-xdbe --enable-xft --enable-gl \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
+}
+
+LEAD_SONAME = "libfltk.so"