aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fltk
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/fltk
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/fltk')
-rw-r--r--packages/fltk/fltk_1.2+cvs20040806.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/fltk/fltk_1.2+cvs20040806.bb b/packages/fltk/fltk_1.2+cvs20040806.bb
index e69de29bb2..b72e357d06 100644
--- a/packages/fltk/fltk_1.2+cvs20040806.bb
+++ b/packages/fltk/fltk_1.2+cvs20040806.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+LICENSE ="LGPL"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Rene Wagner <reenoo@gmx.de>"
+DEPENDS = "jpeg libpng zlib"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous:@cvs.sourceforge.net/cvsroot/fltk;module=fltk;method=pserver;tag=v1_2;date=${@bb.data.getVar('PV', d, 1)[7:]} \
+ file://makefiles.patch;patch=1 \
+ file://autotools.patch;patch=1"
+S="${WORKDIR}/fltk"
+
+inherit autotools binconfig
+
+do_configure_prepend() {
+ autoconf
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += " ${bindir}/fltk-config"
+LEAD_SONAME = "libfltk.so"
+
+EXTRA_OECONF = "--enable-shared --disable-gl"
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk1.2', d)
+}