aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fluxbox
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-09 17:47:15 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-09 17:47:15 +0000
commitbcff6317d2305e76beccd5686d8e76ff23bd43ec (patch)
treeb9af155a4ad852a87b9f8a4861331e84202f9740 /packages/fluxbox
parentc509a64038a7ac5cdee008b38f54c753cf2d57d7 (diff)
downloadopenembedded-bcff6317d2305e76beccd5686d8e76ff23bd43ec.tar.gz
fluxbox: style fixes, unbreak versioning, unbreak packaging, etc, etc
* excessive use of '#' signs is not an excuse for bugs * handwaving while saying 'template' is not an excuse for breaking the style guide
Diffstat (limited to 'packages/fluxbox')
-rw-r--r--packages/fluxbox/fluxbox_0.99+1.0rc.bb101
-rw-r--r--packages/fluxbox/fluxbox_svn.bb104
2 files changed, 85 insertions, 120 deletions
diff --git a/packages/fluxbox/fluxbox_0.99+1.0rc.bb b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
index 68eeeb04b8..d0b52058b8 100644
--- a/packages/fluxbox/fluxbox_0.99+1.0rc.bb
+++ b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
@@ -1,21 +1,15 @@
-#
# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
-#
-# Filename: fluxbox-gpe_1.0rc.bb
-# Date: 01-Jul-06
DESCRIPTION = "The Fluxbox WindowManager"
HOMEPAGE = "http://fluxbox.sourceforge.net"
LICENSE = "MIT"
-REALPV = "1.0rc"
-PR = "r5"
-######################################################################################
+REALPV = "1.0rc"
-S = "${WORKDIR}/fluxbox-${REALPV}"
+PV = "0.99+${REALPV}"
+PR = "r0"
+PE = "1"
-######################################################################################
SRC_URI = "${SOURCEFORGE_MIRROR}/fluxbox/fluxbox-${REALPV}.tar.gz \
file://gpe-init.patch;patch=1 \
@@ -27,69 +21,60 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/fluxbox/fluxbox-${REALPV}.tar.gz \
file://keylaunchrc.fluxbox \
file://gpe-logout.fluxbox"
-######################################################################################
-
-PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
-
-DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
-DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
-RDEPENDS_${PN}-gpe = "${PN}"
-
-######################################################################################
-
-FILES_${PN} = "/usr/bin \
- /usr/share/fluxbox/init \
- /usr/share/fluxbox/keys \
- /usr/share/fluxbox/menu "
-
-FILES_${PN}-gpe = "/usr/share/fluxbox/apps.gpe* \
- /usr/share/fluxbox/keys.* \
- /usr/bin/gpe-logout.fluxbox \
- /etc/keylaunchrc.fluxbox \
- /usr/share/fluxbox/styles/gpe-default \
- /usr/share/fluxbox/session \
- /usr/bin/fluxbox-gpe-session"
-
-FILES_${PN}-styles = "/usr/share/fluxbox/styles"
-
-FILES_${PN}-doc = "/usr/share/man"
-
-######################################################################################
+S = "${WORKDIR}/fluxbox-${REALPV}"
inherit autotools
-######################################################################################
-
EXTRA_OECONF = "--disable-xmb \
"
-######################################################################################
-
do_install_append() {
- install -d ${D}/usr/bin
- install -d ${D}/usr/share/fluxbox
- install -d ${D}/usr/share/fluxbox/styles
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/fluxbox
+ install -d ${D}${datadir}/fluxbox/styles
install -d ${D}/etc
- install -m 0644 ${WORKDIR}/apps.gpe.* ${D}/usr/share/fluxbox
- install -m 0644 ${WORKDIR}/keys.* ${D}/usr/share/fluxbox
- install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}/usr/share/fluxbox/session
- install -m 0644 ${WORKDIR}/style.gpe-default ${D}/usr/share/fluxbox/styles/gpe-default
- install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}/usr/bin
- install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
+ install -m 0644 ${WORKDIR}/apps.gpe.* ${D}${datadir}/fluxbox
+ install -m 0644 ${WORKDIR}/keys.* ${D}${datadir}/fluxbox
+ install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}${datadir}/fluxbox/session
+ install -m 0644 ${WORKDIR}/style.gpe-default ${D}${datadir}/fluxbox/styles/gpe-default
+ install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}${bindir}
+ install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}${bindir}
install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
}
-######################################################################################
+PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
+
+DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
+DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
+RDEPENDS_${PN}-gpe = "${PN}"
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/fluxbox/init \
+ ${datadir}/fluxbox/keys \
+ ${datadir}/fluxbox/menu "
+
+FILES_${PN}-gpe = "${datadir}/fluxbox/apps.gpe* \
+ ${datadir}/fluxbox/keys.* \
+ ${bindir}/gpe-logout.fluxbox \
+ ${sysconfdir}keylaunchrc.fluxbox \
+ ${datadir}/fluxbox/styles/gpe-default \
+ ${datadir}/fluxbox/session \
+ ${bindir}/fluxbox-gpe-session"
+
+FILES_${PN}-styles = "${datadir}/fluxbox/styles"
+
+FILES_${PN}-doc = "${datadir}/man"
+
pkg_postinst_${PN}-gpe() {
- update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/fluxbox-gpe-session 15
- update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.fluxbox 15
- update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.fluxbox 15
+ update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/fluxbox-gpe-session 15
+ update-alternatives --install ${bindir}/gpe-logout gpe-logout ${bindir}/gpe-logout.fluxbox 15
+ update-alternatives --install ${sysconfdir}keylaunchrc keylaunchrc ${sysconfdir}keylaunchrc.fluxbox 15
}
pkg_postrm_${PN}-gpe() {
- update-alternatives --remove x-window-manager /usr/bin/fluxbox-gpe-session
- update-alternatives --remove gpe-logout /usr/bin/gpe-logout.fluxbox
- update-alternatives --remove keylaunchrc /etc/keylaunchrc.fluxbox
+ update-alternatives --remove x-window-manager ${bindir}/fluxbox-gpe-session
+ update-alternatives --remove gpe-logout ${bindir}/gpe-logout.fluxbox
+ update-alternatives --remove keylaunchrc ${sysconfdir}keylaunchrc.fluxbox
}
diff --git a/packages/fluxbox/fluxbox_svn.bb b/packages/fluxbox/fluxbox_svn.bb
index 1034c386c4..bc791bf0e2 100644
--- a/packages/fluxbox/fluxbox_svn.bb
+++ b/packages/fluxbox/fluxbox_svn.bb
@@ -1,25 +1,14 @@
-#
# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
-#
-# Filename: fluxbox-gpe_1.0rc.bb
-# Date: 01-Jul-06
DESCRIPTION = "The Fluxbox WindowManager"
HOMEPAGE = "http://fluxbox.sourceforge.net"
LICENSE = "MIT"
-PV = "1.0+svn${SRCDATE}"
-PR = "r3"
-
-######################################################################################
-
-S = "${WORKDIR}/trunk"
-
-######################################################################################
+PV = "0.99+svn${SRCDATE}"
+PR = "r0"
+PE = "1"
SRC_URI = "svn://svn.berlios.de/fluxbox;module=trunk \
- file://gpe-init.patch;patch=1 \
file://apps.gpe.* \
file://style.gpe-default \
file://fluxbox-gpe-session \
@@ -28,69 +17,60 @@ SRC_URI = "svn://svn.berlios.de/fluxbox;module=trunk \
file://keylaunchrc.fluxbox \
file://gpe-logout.fluxbox"
-######################################################################################
-
-PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
-
-DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
-DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
-RDEPENDS_${PN}-gpe = "${PN}"
-
-######################################################################################
-
-FILES_${PN} = "/usr/bin \
- /usr/share/fluxbox/init \
- /usr/share/fluxbox/keys \
- /usr/share/fluxbox/menu "
-
-FILES_${PN}-gpe = "/usr/share/fluxbox/apps.gpe* \
- /usr/share/fluxbox/keys.* \
- /usr/bin/gpe-logout.fluxbox \
- /etc/keylaunchrc.fluxbox \
- /usr/share/fluxbox/styles/gpe-default \
- /usr/share/fluxbox/session \
- /usr/bin/fluxbox-gpe-session"
-
-FILES_${PN}-styles = "/usr/share/fluxbox/styles"
-
-FILES_${PN}-doc = "/usr/share/man"
-
-######################################################################################
+S = "${WORKDIR}/trunk"
inherit autotools
-######################################################################################
-
EXTRA_OECONF = "--disable-xmb \
"
-######################################################################################
-
do_install_append() {
- install -d ${D}/usr/bin
- install -d ${D}/usr/share/fluxbox
- install -d ${D}/usr/share/fluxbox/styles
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/fluxbox
+ install -d ${D}${datadir}/fluxbox/styles
install -d ${D}/etc
- install -m 0644 ${WORKDIR}/apps.gpe.* ${D}/usr/share/fluxbox
- install -m 0644 ${WORKDIR}/keys.* ${D}/usr/share/fluxbox
- install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}/usr/share/fluxbox/session
- install -m 0644 ${WORKDIR}/style.gpe-default ${D}/usr/share/fluxbox/styles/gpe-default
- install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}/usr/bin
- install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
+ install -m 0644 ${WORKDIR}/apps.gpe.* ${D}${datadir}/fluxbox
+ install -m 0644 ${WORKDIR}/keys.* ${D}${datadir}/fluxbox
+ install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}${datadir}/fluxbox/session
+ install -m 0644 ${WORKDIR}/style.gpe-default ${D}${datadir}/fluxbox/styles/gpe-default
+ install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}${bindir}
+ install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}${bindir}
install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
}
-######################################################################################
+PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
+
+DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
+DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
+RDEPENDS_${PN}-gpe = "${PN}"
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/fluxbox/init \
+ ${datadir}/fluxbox/keys \
+ ${datadir}/fluxbox/menu "
+
+FILES_${PN}-gpe = "${datadir}/fluxbox/apps.gpe* \
+ ${datadir}/fluxbox/keys.* \
+ ${bindir}/gpe-logout.fluxbox \
+ ${sysconfdir}keylaunchrc.fluxbox \
+ ${datadir}/fluxbox/styles/gpe-default \
+ ${datadir}/fluxbox/session \
+ ${bindir}/fluxbox-gpe-session"
+
+FILES_${PN}-styles = "${datadir}/fluxbox/styles"
+
+FILES_${PN}-doc = "${datadir}/man"
+
pkg_postinst_${PN}-gpe() {
- update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/fluxbox-gpe-session 15
- update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.fluxbox 15
- update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.fluxbox 15
+ update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/fluxbox-gpe-session 15
+ update-alternatives --install ${bindir}/gpe-logout gpe-logout ${bindir}/gpe-logout.fluxbox 15
+ update-alternatives --install ${sysconfdir}keylaunchrc keylaunchrc ${sysconfdir}keylaunchrc.fluxbox 15
}
pkg_postrm_${PN}-gpe() {
- update-alternatives --remove x-window-manager /usr/bin/fluxbox-gpe-session
- update-alternatives --remove gpe-logout /usr/bin/gpe-logout.fluxbox
- update-alternatives --remove keylaunchrc /etc/keylaunchrc.fluxbox
+ update-alternatives --remove x-window-manager ${bindir}/fluxbox-gpe-session
+ update-alternatives --remove gpe-logout ${bindir}/gpe-logout.fluxbox
+ update-alternatives --remove keylaunchrc ${sysconfdir}keylaunchrc.fluxbox
}