aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fluxbox
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-07-04 03:06:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-04 03:06:15 +0000
commitd1cc45abeb3a7e4997bd6dc1794f403e43c3568f (patch)
treeceacca27dcb509f6c52b034a717544a2a512ad96 /packages/fluxbox
parent0dd3fdbe060a948e8093487bc562da9c73a1b80b (diff)
downloadopenembedded-d1cc45abeb3a7e4997bd6dc1794f403e43c3568f.tar.gz
fluxbox: Use update-alternative only for fluxbox-gpe, thanks koen for pointint it out. We can't inherit update-alternative since it only works with PN, and horr
ibly b0rks on PN-something.
Diffstat (limited to 'packages/fluxbox')
-rw-r--r--packages/fluxbox/fluxbox_0.99+1.0rc.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/packages/fluxbox/fluxbox_0.99+1.0rc.bb b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
index c222edb817..cf69b090c4 100644
--- a/packages/fluxbox/fluxbox_0.99+1.0rc.bb
+++ b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
@@ -10,7 +10,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
HOMEPAGE = "http://fluxbox.sourceforge.net"
LICENSE = "MIT"
REALPV = "1.0rc"
-PR = "r0"
+PR = "r1"
######################################################################################
@@ -51,7 +51,7 @@ FILES_${PN}-doc = "/usr/share/man"
######################################################################################
-inherit autotools update-alternatives
+inherit autotools
######################################################################################
@@ -73,7 +73,10 @@ do_install_append() {
######################################################################################
-ALTERNATIVE_PATH_${PN}-gpe = "${bindir}/fluxbox-gpe-session"
-ALTERNATIVE_NAME_${PN}-gpe = "x-window-manager"
-ALTERNATIVE_LINK_${PN}-gpe = "${bindir}/x-window-manager"
-ALTERNATIVE_PRIORITY_${PN}-gpe = "15"
+pkg_postinst_${PN}-gpe() {
+ update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/fluxbox-gpe-session 15
+}
+
+pkg_postrm_${PN}-gpe() {
+ update-alternatives --remove x-window-manager /usr/bin/fluxbox-gpe-session
+}