aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fontconfig
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-26 16:04:41 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-26 16:04:41 +0000
commitd04d35bd963361ffe580c95830e791b21fa8d87e (patch)
treef54fe49c6dbbc0d63aeeb6c0050f7bfb3bd5e07a /packages/fontconfig
parentd2414814f650f14ec5b7e2f58a3631e9384b8dfc (diff)
downloadopenembedded-d04d35bd963361ffe580c95830e791b21fa8d87e.tar.gz
fontconfig: apply a patch by Philipp Zabel to stop xtscal from crashing
Diffstat (limited to 'packages/fontconfig')
-rw-r--r--packages/fontconfig/files/one-j-too-many.patch24
-rw-r--r--packages/fontconfig/fontconfig_2.3.95.bb5
2 files changed, 27 insertions, 2 deletions
diff --git a/packages/fontconfig/files/one-j-too-many.patch b/packages/fontconfig/files/one-j-too-many.patch
new file mode 100644
index 0000000000..04d8e0237e
--- /dev/null
+++ b/packages/fontconfig/files/one-j-too-many.patch
@@ -0,0 +1,24 @@
+--- fontconfig-2.3.95/src/fcname.c.orig 2006-07-26 15:20:01.469770388 +0200
++++ fontconfig-2.3.95/src/fcname.c 2006-07-26 15:22:38.415239062 +0200
+@@ -305,17 +305,16 @@
+ FcObjectPtrU (FcObjectPtr si)
+ {
+ const FcObjectTypeList *l;
+- int i, j;
++ int i;
+
+ if (si > 0)
+ {
+ if (si < biggest_known_ntypes)
+ return biggest_known_types[si].object;
+
+- j = 0;
+ for (l = _FcObjectTypes; l; l = l->next)
+- for (i = 0; i < l->ntypes; i++, j++)
+- if (j == si)
++ for (i = 0; i < l->ntypes; i++)
++ if (l->basic_offset+i == si)
+ return l->types[i].object;
+ }
+
+
diff --git a/packages/fontconfig/fontconfig_2.3.95.bb b/packages/fontconfig/fontconfig_2.3.95.bb
index 57f8489a6c..f314b13fc1 100644
--- a/packages/fontconfig/fontconfig_2.3.95.bb
+++ b/packages/fontconfig/fontconfig_2.3.95.bb
@@ -3,9 +3,10 @@ LICENSE = "BSD"
DESCRIPTION = "A library for configuring and customizing font access."
DEPENDS = "expat freetype freetype-native zlib"
-SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz"
+SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
+ file://one-j-too-many.patch;patch=1"
-PR = "r0"
+PR = "r1"
PACKAGES =+ "fontconfig-utils "
FILES_fontconfig-utils = "${bindir}/*"