aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fontconfig
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-05-31 22:34:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 22:34:36 +0000
commitd784bf8174ba1df53d37149a34d8652911983fdb (patch)
tree721b6fc1d4f5d79b4ff72a0584d5c49e66f7e89f /packages/fontconfig
parent3d908ebe7ecb2ada557b7b6cc094182b4ec6613a (diff)
downloadopenembedded-d784bf8174ba1df53d37149a34d8652911983fdb.tar.gz
fontconfig - Add a local.conf file
Diffstat (limited to 'packages/fontconfig')
-rw-r--r--packages/fontconfig/files/local.conf9
-rw-r--r--packages/fontconfig/fontconfig_2.2.95.bb8
2 files changed, 14 insertions, 3 deletions
diff --git a/packages/fontconfig/files/local.conf b/packages/fontconfig/files/local.conf
index ddd7cf9d03..d678878f3e 100644
--- a/packages/fontconfig/files/local.conf
+++ b/packages/fontconfig/files/local.conf
@@ -2,11 +2,18 @@
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
-<!-- Enable sub-pixel rendering -->
+<!--
+ Enable sub-pixel rendering
<match target="font">
<test qual="all" name="rgba">
<const>unknown</const>
</test>
<edit name="rgba" mode="assign"><const>rgb</const></edit>
</match>
+-->
+
+<!-- X11R7.0 installs fonts to a new location -->
+ <dir>/usr/lib/X11/fonts/misc</dir>
+ <dir>/usr/lib/X11/fonts/Type1</dir>
+ <dir>/usr/lib/X11/fonts/75dpi</dir>
</fontconfig>
diff --git a/packages/fontconfig/fontconfig_2.2.95.bb b/packages/fontconfig/fontconfig_2.2.95.bb
index 7ff731ebe8..0951d40626 100644
--- a/packages/fontconfig/fontconfig_2.2.95.bb
+++ b/packages/fontconfig/fontconfig_2.2.95.bb
@@ -5,8 +5,9 @@ DEPENDS = "expat freetype freetype-native zlib fontconfig-native"
SRC_URI = "http://freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz \
file://fc-glyphname.patch;patch=1 \
- file://fc-lang.patch;patch=1"
-PR = "r6"
+ file://fc-lang.patch;patch=1 \
+ file://local.conf"
+PR = "r7"
PACKAGES =+ "fontconfig-utils "
FILES_fontconfig-utils = "${bindir}/*"
@@ -46,5 +47,8 @@ do_stage () {
do_install () {
autotools_do_install
+
+ install -d ${D}/etc/fonts/
+ install -m 0644 ${WORKDIR}/local.conf ${D}/etc/fonts/
}