aboutsummaryrefslogtreecommitdiffstats
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-16 03:05:05 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-16 03:05:05 +0100
commit5e27628f3ff4af00bdf28325d3cc7d5901e6e0d1 (patch)
tree2d7ced23ad6d88cc81fe2fb0aa1c0c4bcb9396c0 /packages/freesmartphone
parentf639862e7d0944806684a7700830bf6bbe4e20a0 (diff)
downloadopenembedded-5e27628f3ff4af00bdf28325d3cc7d5901e6e0d1.tar.gz
fsod: new recipe, a C/Vala implementation of the freesmartphone.org dbus APIs
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/fsod_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/freesmartphone/fsod_git.bb b/packages/freesmartphone/fsod_git.bb
new file mode 100644
index 0000000000..278331326e
--- /dev/null
+++ b/packages/freesmartphone/fsod_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The C/Vala implementation of the freesmartphone.org framework APIs"
+HOMEPAGE = "http://www.freesmartphone.org/"
+AUTHOR = "Sudharshan S"
+SECTION = "console/network"
+DEPENDS = "dbus dbus-glib libnl vala-native"
+LICENSE = "LGPL"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/openmoko-gsoc2008.git;protocol=git;branch=master \
+# file://fsod \
+"
+S = "${WORKDIR}/git/fsod"
+
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_NAME = "fsod"
+INITSCRIPT_PARAMS = "defaults 21"
+
+do_install_append() {
+# install -d ${D}${sysconfdir}/init.d
+# install -m 0755 ${WORKDIR}/fsod ${D}${sysconfdir}/init.d/
+}
+
+RCONFLICTS_${PN} = "frameworkd"
+RREPLACES_${PN} = "frameworkd"
+
+FILES_${PN} += "${sysconfdir}"
+FILES_${PN}-dbg += "\
+ ${libdir}/fsod/subsystems/.debug \
+ ${libdir}/fsod/subsystems/*/.debug \
+"
+