aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ftpd-topfield
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-09-07 03:58:39 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-07 03:58:39 +0000
commitbe9f46dc283647519bbe309face327f0b659076c (patch)
tree458932452eae1c60976752a667228c8aab000e3b /packages/ftpd-topfield
parent56a690e70b1b767625bd7aa2ed5cda4371889530 (diff)
downloadopenembedded-be9f46dc283647519bbe309face327f0b659076c.tar.gz
ftpd-topfield: updated to 0.6.0
Diffstat (limited to 'packages/ftpd-topfield')
-rw-r--r--packages/ftpd-topfield/ftpd-topfield_0.6.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.6.0.bb b/packages/ftpd-topfield/ftpd-topfield_0.6.0.bb
new file mode 100644
index 0000000000..06cd4732d7
--- /dev/null
+++ b/packages/ftpd-topfield/ftpd-topfield_0.6.0.bb
@@ -0,0 +1,39 @@
+# This package builds the ftpd-topfield program
+PR = "r0"
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
+SECTION = "net"
+LICENSE = "MIT"
+
+DEPENDS = "libusb"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_6_0 \
+ cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=LIBTOPFIELD_0_5_0 \
+ file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+SL = "${WORKDIR}/libtopfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake -C ${SL} libtopfield.a
+ oe_runmake LDLIBS="${LDFLAGS} -L ../libtopfield -ltopfield -lusb"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}