aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ftpd-topfield
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/ftpd-topfield
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/ftpd-topfield')
-rw-r--r--packages/ftpd-topfield/.mtn2git_empty0
-rw-r--r--packages/ftpd-topfield/files/.mtn2git_empty0
-rw-r--r--packages/ftpd-topfield/files/init40
-rw-r--r--packages/ftpd-topfield/ftpd-topfield_0.5.1.bb39
4 files changed, 79 insertions, 0 deletions
diff --git a/packages/ftpd-topfield/.mtn2git_empty b/packages/ftpd-topfield/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ftpd-topfield/.mtn2git_empty
diff --git a/packages/ftpd-topfield/files/.mtn2git_empty b/packages/ftpd-topfield/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ftpd-topfield/files/.mtn2git_empty
diff --git a/packages/ftpd-topfield/files/init b/packages/ftpd-topfield/files/init
index e69de29bb2..a4cd501e10 100644
--- a/packages/ftpd-topfield/files/init
+++ b/packages/ftpd-topfield/files/init
@@ -0,0 +1,40 @@
+#!/bin/sh
+DAEMON=/usr/sbin/ftpd-topfield
+NAME=ftpd-topfield
+DESC="FTP daemon for the Topfield PVR"
+ARGS="-D -e"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "starting $DESC: $NAME... "
+ test -d /var/lib/misc/ || mkdir /var/lib/misc/
+ start-stop-daemon -S -x $DAEMON -- $ARGS
+ echo "done."
+ ;;
+ stop)
+ echo -n "stopping $DESC: $NAME... "
+ start-stop-daemon -K -x $DAEMON
+ echo "done."
+ ;;
+ restart)
+ echo "restarting $DESC: $NAME... "
+ $0 stop
+ $0 start
+ echo "done."
+ ;;
+ reload)
+ echo -n "reloading $DESC: $NAME... "
+ killall -HUP $(basename ${DAEMON})
+ echo "done."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.5.1.bb b/packages/ftpd-topfield/ftpd-topfield_0.5.1.bb
index e69de29bb2..0cfeaeca83 100644
--- a/packages/ftpd-topfield/ftpd-topfield_0.5.1.bb
+++ b/packages/ftpd-topfield/ftpd-topfield_0.5.1.bb
@@ -0,0 +1,39 @@
+# This package builds the ftpd-topfield program
+PR = "r0"
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
+SECTION = "net"
+LICENSE = "MIT"
+
+DEPENDS = libusb
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_5_1 \
+ cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=LIBTOPFIELD_0_5_0 \
+ file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+SL = "${WORKDIR}/libtopfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake -C ${SL} libtopfield.a
+ oe_runmake LDLIBS="${LDFLAGS} -L ../libtopfield -ltopfield -lusb"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}