aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fuse
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-11-13 21:49:20 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-11-13 21:49:20 +0000
commitb23ff155cb2e3fdd3a5a390a621ff982bda060aa (patch)
tree84380073dca6f9c51633a0b458893c3e5b1fa812 /packages/fuse
parentf7171587f09b13c97cc73109cd9eaf7c5aa78e47 (diff)
downloadopenembedded-b23ff155cb2e3fdd3a5a390a621ff982bda060aa.tar.gz
gmailfs: re-added broken version - koen will fix it
Diffstat (limited to 'packages/fuse')
-rw-r--r--packages/fuse/gmailfs_0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/fuse/gmailfs_0.6.bb b/packages/fuse/gmailfs_0.6.bb
new file mode 100644
index 0000000000..eff0e0f630
--- /dev/null
+++ b/packages/fuse/gmailfs_0.6.bb
@@ -0,0 +1,22 @@
+BROKEN = "1"
+DESCRIPTION = "GmailFS provides a mountable Linux filesystem which uses your Gmail account as its storage medium."
+HOMEPAGE = "http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html"
+LICENSE = "GPL"
+
+DEPENDS = "fuse libgmail python-fuse"
+RDEPENDS = "fuse libgmail python-fuse python-unixadmin python-lang python-textutils python-core"
+
+SRC_URI = "http://richard.jones.name/google-hacks/gmail-filesystem/gmailfs-0.6.tar.gz"
+
+
+do_install() {
+install -d ${D}${datadir}/gmailfs
+install -d ${D}${bindir}
+install -d ${D}${sysconfdir}
+
+install -m 755 ${S}/gmailfs.py ${D}${datadir}/gmailfs/
+install -m 755 ${S}/mount.gmailfs ${D}${bindir}
+install -m 644 ${S}/*.conf ${D}${sysconfdir}
+
+}
+