aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fuse
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-03-10 05:00:46 +0000
committerMike Westerhof <mwester@dls.net>2007-03-10 05:00:46 +0000
commitf0538870969c76fea25d8c0b119a28ee6d20268c (patch)
tree7c812c9d0c9be8a49f9b3ea5ec9621f64427cfc9 /packages/fuse
parentd9ec3df9f83d9285313e0875b4aa2329431f6be6 (diff)
downloadopenembedded-f0538870969c76fea25d8c0b119a28ee6d20268c.tar.gz
fuse: upgrade to 2.6.3 from upstream; remove dependency on the fuse kernel
module as we wish to use the fuse module provided with recent kernels.
Diffstat (limited to 'packages/fuse')
-rw-r--r--packages/fuse/fuse-2.6.3/.mtn2git_empty0
-rw-r--r--packages/fuse/fuse-2.6.3/not-run-updaterc.d-on-host.patch21
-rw-r--r--packages/fuse/fuse_2.6.3.bb22
3 files changed, 43 insertions, 0 deletions
diff --git a/packages/fuse/fuse-2.6.3/.mtn2git_empty b/packages/fuse/fuse-2.6.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fuse/fuse-2.6.3/.mtn2git_empty
diff --git a/packages/fuse/fuse-2.6.3/not-run-updaterc.d-on-host.patch b/packages/fuse/fuse-2.6.3/not-run-updaterc.d-on-host.patch
new file mode 100644
index 0000000000..2496b77f70
--- /dev/null
+++ b/packages/fuse/fuse-2.6.3/not-run-updaterc.d-on-host.patch
@@ -0,0 +1,21 @@
+--- fuse-2.6.3/util/Makefile.am~ 2007-02-27 22:50:15.000000000 -0600
++++ fuse-2.6.3/util/Makefile.am 2007-02-27 22:53:31.000000000 -0600
+@@ -29,10 +29,6 @@
+ $(INSTALL_PROGRAM) $(srcdir)/mount.fuse $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
+ $(mkdir_p) $(DESTDIR)$(INIT_D_PATH)
+ $(INSTALL_PROGRAM) $(srcdir)/init_script $(DESTDIR)$(INIT_D_PATH)/fuse
+- @if test -x /usr/sbin/update-rc.d; then \
+- echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true"; \
+- /usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true; \
+- fi
+
+ install-data-local:
+ $(mkdir_p) $(DESTDIR)$(UDEV_RULES_PATH)
+@@ -42,7 +38,3 @@
+ rm -f $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
+ rm -f $(DESTDIR)$(UDEV_RULES_PATH)/99-fuse.rules
+ rm -f $(DESTDIR)$(INIT_D_PATH)/fuse
+- @if test -x /usr/sbin/update-rc.d; then \
+- echo "/usr/sbin/update-rc.d fuse remove || true"; \
+- /usr/sbin/update-rc.d fuse remove || true; \
+- fi
diff --git a/packages/fuse/fuse_2.6.3.bb b/packages/fuse/fuse_2.6.3.bb
new file mode 100644
index 0000000000..f85860f175
--- /dev/null
+++ b/packages/fuse/fuse_2.6.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+HOMEPAGE = "http://fuse.sf.net"
+LICENSE = "GPL"
+DEPENDS = "fakeroot-native"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz \
+ file://not-run-updaterc.d-on-host.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_stage() {
+ autotools_stage_all
+}
+
+# Package the fuse utils and libs in seperate packages
+PACKAGES += "lib${PN} libulockmgr"
+FILES_${PN}-dev += "${libdir}/*.la"
+FILES_lib${PN} = "${libdir}/libfuse*.so.*"
+FILES_libulockmgr = "${libdir}/libulockmgr.so.*"