aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gal/gal-2.1_2.1.10.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gal/gal-2.1_2.1.10.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gal/gal-2.1_2.1.10.bb')
-rw-r--r--packages/gal/gal-2.1_2.1.10.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gal/gal-2.1_2.1.10.bb b/packages/gal/gal-2.1_2.1.10.bb
index e69de29bb2..ee76f21f0a 100644
--- a/packages/gal/gal-2.1_2.1.10.bb
+++ b/packages/gal/gal-2.1_2.1.10.bb
@@ -0,0 +1,21 @@
+LICENSE = GPL
+SECTION = "x11/libs"
+DEPENDS = "intltool libgnomeprint gtk+ libglade libgnomeui libgnomecanvas libxml2 libgnomeprintui"
+
+inherit gnome
+
+SRC_URI = "${GNOME_MIRROR}/gal/2.1/gal-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://forward-decl.patch;patch=1 \
+ file://iconv-detect.h"
+
+S = "${WORKDIR}/gal-${PV}"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/iconv-detect.h ${S}/
+}
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -C gal -so -a libgal-2.2 ${STAGING_LIBDIR}
+}