aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gallery
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2006-12-07 19:51:49 +0000
committerAndrew Wilcox <andy@protium.com>2006-12-07 19:51:49 +0000
commitc080889c68bbbfa5797f716ff73e3370fb125343 (patch)
tree511bbe6755be199d4bba90d0c9cc508c9e8551f0 /packages/gallery
parent7d4a04338043aa1dd4668ff04fb1ff8188673a2c (diff)
downloadopenembedded-c080889c68bbbfa5797f716ff73e3370fb125343.tar.gz
gallery: the popular web photo gallery
Diffstat (limited to 'packages/gallery')
-rw-r--r--packages/gallery/.mtn2git_empty0
-rw-r--r--packages/gallery/files/.mtn2git_empty0
-rw-r--r--packages/gallery/files/gallery.conf31
-rw-r--r--packages/gallery/gallery_1.5.5.bb40
4 files changed, 71 insertions, 0 deletions
diff --git a/packages/gallery/.mtn2git_empty b/packages/gallery/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gallery/.mtn2git_empty
diff --git a/packages/gallery/files/.mtn2git_empty b/packages/gallery/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gallery/files/.mtn2git_empty
diff --git a/packages/gallery/files/gallery.conf b/packages/gallery/files/gallery.conf
new file mode 100644
index 0000000000..b773e2c24f
--- /dev/null
+++ b/packages/gallery/files/gallery.conf
@@ -0,0 +1,31 @@
+<IfDefine PHP5>
+
+<Directory /usr/share/apache2/htdocs/gallery>
+
+php_value post_max_size 20971520
+php_value upload_max_filesize 20971520
+php_value magic_quotes_gpc off
+php_value session.save_handler files
+php_value register_globals off
+
+Options -Indexes +FollowSymLinks
+
+<IfModule mod_rewrite.c>
+RewriteEngine On
+RewriteBase /gallery/
+
+# Ensure that the requested gallery is not a valid directory
+# This can cause an infinite redirection loop
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/([0-9]+)$ /gallery/view_photo.php?set_albumName=$1/index=$2 [QSA]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$ /gallery/view_photo.php?set_albumName=$1/id=$2 [QSA]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/$ /gallery/$1 [R]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)$ /gallery/view_album.php?set_albumName=$1 [QSA]
+</IfModule>
+
+</Directory>
+
+</IfDefine>
diff --git a/packages/gallery/gallery_1.5.5.bb b/packages/gallery/gallery_1.5.5.bb
new file mode 100644
index 0000000000..1e2c36b711
--- /dev/null
+++ b/packages/gallery/gallery_1.5.5.bb
@@ -0,0 +1,40 @@
+SECTION = "apps"
+DESCRIPTION = "The Gallery v1 web image gallery"
+LICENSE = "GPL"
+#
+RDEPENDS = "apache2 modphp imagemagick jhead"
+
+PR = "r1"
+S = "${WORKDIR}/gallery"
+HTTPCONF=/etc/apache2/httpd.conf
+DEST_DIR=/usr/share/apache2/htdocs/
+#
+# don't list the albums as a file - it might get auto-deleted
+#
+FILES_${PN} = "${DEST_DIR}/gallery /etc/apache2/modules.d"
+
+SRC_URI = "http://easynews.dl.sourceforge.net/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
+
+inherit autotools
+
+# No configure step for gallery
+do_configure() {
+ :
+}
+
+# No compile step either
+do_compile() {
+ :
+}
+
+#
+do_install() {
+ mkdir -p ${D}/${DEST_DIR} ${D}/etc/apache2/modules.d
+ cp -a ${S} ${D}/${DEST_DIR}
+ cp ${FILESDIR}/gallery.conf ${D}/etc/apache2/modules.d/95_gallery.conf
+}
+
+# remove the gallery code, but not the albums!
+pkg_postrm_${PN}() {
+ rm -rf ${DEST_DIR}/gallery /etc/apache2/modules.d/95_gallery.conf
+}