aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gammu
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2008-05-13 15:38:20 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2008-05-13 15:38:20 +0000
commit99c07ae16659f6316801647e3335a27212f78ce6 (patch)
tree491a1667469886856cef9629bb77285bd371375d /packages/gammu
parent8ca9299bb70feee80e82622a36184b1b56dff2e5 (diff)
downloadopenembedded-99c07ae16659f6316801647e3335a27212f78ce6.tar.gz
gammu: updated to 1.20.0
Diffstat (limited to 'packages/gammu')
-rw-r--r--packages/gammu/files/.mtn2git_empty0
-rw-r--r--packages/gammu/files/ldflags-again.patch13
-rw-r--r--packages/gammu/gammu_1.17.0.bb35
-rw-r--r--packages/gammu/gammu_1.20.0.bb20
4 files changed, 20 insertions, 48 deletions
diff --git a/packages/gammu/files/.mtn2git_empty b/packages/gammu/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gammu/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gammu/files/ldflags-again.patch b/packages/gammu/files/ldflags-again.patch
deleted file mode 100644
index 90311e5f39..0000000000
--- a/packages/gammu/files/ldflags-again.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: gammu-1.10.0/cfg/Makefile.glo
-===================================================================
---- gammu-1.10.0.orig/cfg/Makefile.glo 2007-03-30 17:55:18.000000000 +0200
-+++ gammu-1.10.0/cfg/Makefile.glo 2007-03-30 17:55:46.000000000 +0200
-@@ -152,7 +152,7 @@
-
- $(TOPDIR)/gammu/gammu-shared: $(COMMON) $(GAMMU) $(TOPDIR)/common/$(LIBGAMMU_FULLNAME)
- @echo Linking gammu-shared
-- @$(CC) -L$(TOPDIR)/common -lGammu $(GAMMU_CFLAGS) $(GAMMU_LIBS) $(SMSD_LIBS) $(GAMMU) -o $(TOPDIR)/gammu/gammu-shared
-+ @$(CC) -L$(TOPDIR)/common -lGammu $(LDLIBS) $(GAMMU_CFLAGS) $(GAMMU_LIBS) $(SMSD_LIBS) $(GAMMU) -o $(TOPDIR)/gammu/gammu-shared
-
- shared: $(TOPDIR)/common/$(LIBGAMMU_FULLNAME) $(TOPDIR)/common/$(LIBGAMMU_STATIC) $(TOPDIR)/gammu/gammu-shared
-
diff --git a/packages/gammu/gammu_1.17.0.bb b/packages/gammu/gammu_1.17.0.bb
deleted file mode 100644
index 65ab877495..0000000000
--- a/packages/gammu/gammu_1.17.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "GNU All Mobile Managment Utilities"
-SECTION = "console/network"
-DEPENDS = "bluez-libs cmake-native"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.gammu.org/"
-PR = "r1"
-
-SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
-
-inherit pkgconfig
-
-do_configure() {
- cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
-}
-
-do_compile () {
- oe_runmake
-}
-
-do_install () {
- oe_runmake install DESTDIR=${D}
-}
-
-do_stage() {
- install -d ${STAGING_INCDIR}/gammu/
- install -m 0644 build-configure/include/*.h ${STAGING_INCDIR}/gammu/
-
- oe_libinstall -so -C build-configure/common libGammu ${STAGING_LIBDIR}
- rm -f ./build-configure/pkgconfig/gammu.pc
-}
-
-PACKAGES =+ "libgammu"
-
-FILES_${PN} = "${bindir}/gammu"
-FILES_libgammu = "${libdir}/libGammu.so*"
diff --git a/packages/gammu/gammu_1.20.0.bb b/packages/gammu/gammu_1.20.0.bb
new file mode 100644
index 0000000000..a927e2a70b
--- /dev/null
+++ b/packages/gammu/gammu_1.20.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
+
+# it is CMake based but when inherit cmake it builds static binary/library
+inherit autotools pkgconfig
+
+do_configure() {
+ cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+PACKAGES =+ "libgammu"
+
+FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker"
+FILES_${PN}-dev += "${bindir}/gammu-config"
+FILES_libgammu = "${libdir}/libGammu.so.*"