aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gawk
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-10 04:11:56 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-10 04:11:56 +0000
commitb123d379836c1d5d5a55a6e7bcdf5becf4d8a2cf (patch)
tree5351ea6fec8ae1823863b7bffe4dc76a31537cb0 /packages/gawk
parentd89a1abf8213fc786482d37e17a6a0561822b8b5 (diff)
downloadopenembedded-b123d379836c1d5d5a55a6e7bcdf5becf4d8a2cf.tar.gz
gawk 3.1.4: Run sanitize.py over the recipe.
Diffstat (limited to 'packages/gawk')
-rw-r--r--packages/gawk/gawk_3.1.4.bb27
1 files changed, 13 insertions, 14 deletions
diff --git a/packages/gawk/gawk_3.1.4.bb b/packages/gawk/gawk_3.1.4.bb
index c860454e5f..9594127b08 100644
--- a/packages/gawk/gawk_3.1.4.bb
+++ b/packages/gawk/gawk_3.1.4.bb
@@ -1,30 +1,29 @@
-LICENSE = "GPL"
-SECTION = "interpreters"
DESCRIPTION = "A program that you can use to select particular records in a \
file and perform operations upon them."
-PR = "r3"
-PACKAGES += "gawk-common pgawk"
-FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
-FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
-FILES_pgawk = "${bindir}/pgawk*"
-FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
+SECTION = "interpreters"
+LICENSE = "GPL"
RDEPENDS_gawk += "gawk-common"
RDEPENDS_pgawk += "gawk-common"
+PR = "r3"
SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz"
inherit autotools
do_configure_prepend () {
- grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
+ grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
}
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/awk awk gawk 100
-}
+PACKAGES += "gawk-common pgawk"
+FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
+FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
+FILES_pgawk = "${bindir}/pgawk*"
+FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/awk awk gawk 100
+}
pkg_prerm_${PN} () {
- update-alternatives --remove awk gawk
+ update-alternatives --remove awk gawk
}
-