aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc-snapshot
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/gcc-snapshot
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/gcc-snapshot')
-rw-r--r--packages/gcc-snapshot/gcc-snapshot-cross_cvs.bb22
-rw-r--r--packages/gcc-snapshot/gcc-snapshot_cvs.bb20
2 files changed, 21 insertions, 21 deletions
diff --git a/packages/gcc-snapshot/gcc-snapshot-cross_cvs.bb b/packages/gcc-snapshot/gcc-snapshot-cross_cvs.bb
index d92b09f2b3..4e2f7fa91b 100644
--- a/packages/gcc-snapshot/gcc-snapshot-cross_cvs.bb
+++ b/packages/gcc-snapshot/gcc-snapshot-cross_cvs.bb
@@ -69,25 +69,25 @@ do_install () {
oe_runmake 'DESTDIR=${D}' install
# Move libgcc_s into /lib
- mkdir -p ${D}/${base_libdir}
- if [ -f ${D}/${base_libdir}/libgcc_s.so.? ]; then
+ mkdir -p ${D}${base_libdir}
+ if [ -f ${D}${base_libdir}/libgcc_s.so.? ]; then
# Already in the right location
:
- elif [ -f ${D}/${prefix}/lib/libgcc_s.so.? ]; then
- mv -f ${D}/${prefix}/lib/libgcc_s.so.* ${D}/${base_libdir}
+ elif [ -f ${D}${prefix}/lib/libgcc_s.so.? ]; then
+ mv -f ${D}${prefix}/lib/libgcc_s.so.* ${D}${base_libdir}
else
- mv -f ${D}/${prefix}/*/lib/libgcc_s.so.* ${D}/${base_libdir}
+ mv -f ${D}${prefix}/*/lib/libgcc_s.so.* ${D}${base_libdir}
fi
# Move libstdc++ and libg2c into libdir (resetting our prefix to /usr
TGT_LIBDIR=`echo ${libdir} | sed -e 's,${CROSS_DIR},/usr,'`
- mkdir -p ${D}/${TGT_LIBDIR}
- mv -f ${D}/${prefix}/*/lib/libstdc++.so.* ${D}/${TGT_LIBDIR}
- mv -f ${D}/${prefix}/*/lib/libg2c.so.* ${D}/${TGT_LIBDIR}
+ mkdir -p ${D}${TGT_LIBDIR}
+ mv -f ${D}${prefix}/*/lib/libstdc++.so.* ${D}${TGT_LIBDIR}
+ mv -f ${D}${prefix}/*/lib/libg2c.so.* ${D}${TGT_LIBDIR}
# Manually run the target stripper since we won't get it run by
# the packaging.
- ${TARGET_PREFIX}strip ${D}/${TGT_LIBDIR}/libstdc++.so.*
- ${TARGET_PREFIX}strip ${D}/${TGT_LIBDIR}/libg2c.so.*
- ${TARGET_PREFIX}strip ${D}/${base_libdir}gcc_s.so.*
+ ${TARGET_PREFIX}strip ${D}${TGT_LIBDIR}/libstdc++.so.*
+ ${TARGET_PREFIX}strip ${D}${TGT_LIBDIR}/libg2c.so.*
+ ${TARGET_PREFIX}strip ${D}${base_libdir}gcc_s.so.*
}
diff --git a/packages/gcc-snapshot/gcc-snapshot_cvs.bb b/packages/gcc-snapshot/gcc-snapshot_cvs.bb
index f7c1a0ec09..bf87651e75 100644
--- a/packages/gcc-snapshot/gcc-snapshot_cvs.bb
+++ b/packages/gcc-snapshot/gcc-snapshot_cvs.bb
@@ -167,28 +167,28 @@ do_install () {
autotools_do_install
# Cleanup some of the ${libdir}{,exec}/gcc stuff ...
- rm -r ${D}/${libdir}/gcc/${TARGET_SYS}/${PV}/install-tools
- rm -r ${D}/${libexecdir}/gcc/${TARGET_SYS}/${PV}/install-tools
+ rm -r ${D}${libdir}/gcc/${TARGET_SYS}/${PV}/install-tools
+ rm -r ${D}${libexecdir}/gcc/${TARGET_SYS}/${PV}/install-tools
# Move libgcc_s into /lib
- mkdir -p ${D}/${base_libdir}
- mv ${D}/${libdir}/libgcc_s.so.* ${D}/${base_libdir}
- rm ${D}/${libdir}/libgcc_s.so
+ mkdir -p ${D}${base_libdir}
+ mv ${D}${libdir}/libgcc_s.so.* ${D}${base_libdir}
+ rm ${D}${libdir}/libgcc_s.so
ln -sf `echo ${libdir}/gcc/${TARGET_SYS}/${PV} \
| tr -s / \
| sed -e 's,^/,,' -e 's,[^/]*,..,g'`/lib/libgcc_s.so.? \
- ${D}/${libdir}/gcc/${TARGET_SYS}/${PV}/libgcc_s.so
+ ${D}${libdir}/gcc/${TARGET_SYS}/${PV}/libgcc_s.so
# We don't need libtool libraries
- rm ${D}/${libdir}/libg2c.la
+ rm ${D}${libdir}/libg2c.la
# Cleanup manpages..
- rm -r ${D}/${mandir}/man7
+ rm -r ${D}${mandir}/man7
# We use libiberty from binutils
- rm ${D}/${libdir}/libiberty.a
+ rm ${D}${libdir}/libiberty.a
- cd ${D}/${bindir}
+ cd ${D}${bindir}
# We care about g++ not c++
rm *c++