aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/gcc-cross_3.3.4.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/gcc/gcc-cross_3.3.4.bb
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/gcc/gcc-cross_3.3.4.bb')
-rw-r--r--packages/gcc/gcc-cross_3.3.4.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/packages/gcc/gcc-cross_3.3.4.bb b/packages/gcc/gcc-cross_3.3.4.bb
index 3abf6f0103..997c5044a7 100644
--- a/packages/gcc/gcc-cross_3.3.4.bb
+++ b/packages/gcc/gcc-cross_3.3.4.bb
@@ -76,25 +76,25 @@ do_install () {
oe_runmake 'DESTDIR=${D}' install
# Move libgcc_s into /lib
- mkdir -p ${D}/${base_libdir}
+ mkdir -p ${D}${base_libdir}
if [ "${BUILD_SYS}" == "${TARGET_SYS}" ]; then
# native builds drop one pathname component
- mv -f ${D}/${prefix}/lib/libgcc_s.so.* ${D}/${base_libdir}
+ mv -f ${D}${prefix}/lib/libgcc_s.so.* ${D}${base_libdir}
else
- mv -f ${D}/${prefix}/*/lib/libgcc_s.so.* ${D}/${base_libdir}
+ mv -f ${D}${prefix}/*/lib/libgcc_s.so.* ${D}${base_libdir}
fi
# Move libstdc++ and libg2c into libdir (resetting our prefix to /usr
TGT_LIBDIR=`echo ${libdir} | sed -e 's,${CROSS_DIR},/usr,'`
- mkdir -p ${D}/${TGT_LIBDIR}
- mv -f ${D}/${prefix}/*/lib/libstdc++.so.* ${D}/${TGT_LIBDIR}
- mv -f ${D}/${prefix}/*/lib/libg2c.so.* ${D}/${TGT_LIBDIR}
+ mkdir -p ${D}${TGT_LIBDIR}
+ mv -f ${D}${prefix}/*/lib/libstdc++.so.* ${D}${TGT_LIBDIR}
+ mv -f ${D}${prefix}/*/lib/libg2c.so.* ${D}${TGT_LIBDIR}
# Manually run the target stripper since we won't get it run by
# the packaging.
if [ "x${OLD_INHIBIT_PACKAGE_STRIP}" != "x1" ]; then
- ${TARGET_PREFIX}strip ${D}/${TGT_LIBDIR}/libstdc++.so.*
- ${TARGET_PREFIX}strip ${D}/${TGT_LIBDIR}/libg2c.so.*
- ${TARGET_PREFIX}strip ${D}/${base_libdir}/libgcc_s.so.*
+ ${TARGET_PREFIX}strip ${D}${TGT_LIBDIR}/libstdc++.so.*
+ ${TARGET_PREFIX}strip ${D}${TGT_LIBDIR}/libg2c.so.*
+ ${TARGET_PREFIX}strip ${D}${base_libdir}/libgcc_s.so.*
fi
}