aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/gcc-cross_4.2-20060513.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-05-14 18:46:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-14 18:46:52 +0000
commit5eebb2ac56a6d1a945799adf510db1005d6bf6bb (patch)
treed95ebe4fb63a9ca1d367d5eb2aca2bda9b99cc29 /packages/gcc/gcc-cross_4.2-20060513.bb
parent71e7ac0d631082111da2c1962c8530e71acd2595 (diff)
downloadopenembedded-5eebb2ac56a6d1a945799adf510db1005d6bf6bb.tar.gz
add latest gcc 4.2 snapshot for gcc-cross
Diffstat (limited to 'packages/gcc/gcc-cross_4.2-20060513.bb')
-rw-r--r--packages/gcc/gcc-cross_4.2-20060513.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.2-20060513.bb b/packages/gcc/gcc-cross_4.2-20060513.bb
new file mode 100644
index 0000000000..4b0b5a1311
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.2-20060513.bb
@@ -0,0 +1,18 @@
+include gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-build-cross.inc
+# cross packaging
+include gcc-package-cross.inc
+
+EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"