aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-01 14:59:48 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-01 14:59:48 +0000
commit27f69443f5d63b18bed1baa9112b94a7df61acbf (patch)
tree1b7e95bca823f75084e413075fa231c8e11aee1c /packages/gcc
parentfcdbb1db35bbd3a20e9d25b8499b6a8549b5d26c (diff)
downloadopenembedded-27f69443f5d63b18bed1baa9112b94a7df61acbf.tar.gz
gcc 4.0.2: remove hunk that patches version.c
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.0.2/gcc-4.0.2-atmel.0.99.2.patch31
-rw-r--r--packages/gcc/gcc-cross_4.0.2.bb2
-rw-r--r--packages/gcc/gcc_4.0.2.bb2
3 files changed, 2 insertions, 33 deletions
diff --git a/packages/gcc/gcc-4.0.2/gcc-4.0.2-atmel.0.99.2.patch b/packages/gcc/gcc-4.0.2/gcc-4.0.2-atmel.0.99.2.patch
index a8d9aff6e1..4e8993c7c2 100644
--- a/packages/gcc/gcc-4.0.2/gcc-4.0.2-atmel.0.99.2.patch
+++ b/packages/gcc/gcc-4.0.2/gcc-4.0.2-atmel.0.99.2.patch
@@ -20373,37 +20373,6 @@ diff -Nrup --ignore-space-change gcc-4.0.2/gcc/tree-ssa-operands.c gcc-4.0.2-atm
s_ann->has_volatile_ops = true;
get_expr_operands (stmt, &TREE_OPERAND (expr, 2), opf_none);
}
-diff -Nrup --ignore-space-change gcc-4.0.2/gcc/version.c gcc-4.0.2-atmel.0.99.2/gcc/version.c
---- gcc-4.0.2/gcc/version.c 2005-09-21 05:58:56.000000000 +0200
-+++ gcc-4.0.2-atmel.0.99.2/gcc/version.c 2006-12-01 12:45:38.000000000 +0100
-@@ -5,7 +5,7 @@
- please modify this string to indicate that, e.g. by putting your
- organization's name in parentheses at the end of the string. */
-
--const char version_string[] = "4.0.2";
-+const char version_string[] = "4.0.2-atmel.0.99.2";
-
- /* This is the location of the online document giving instructions for
- reporting bugs. If you distribute a modified version of GCC,
-@@ -14,4 +14,4 @@ const char version_string[] = "4.0.2";
- forward us bugs reported to you, if you determine that they are
- not bugs in your modifications.) */
-
--const char bug_report_url[] = "<URL:http://gcc.gnu.org/bugs.html>";
-+const char bug_report_url[] = "<URL:http://www.atmel.com/avr32/>";
-diff -Nrup --ignore-space-change gcc-4.0.2/LAST_UPDATED gcc-4.0.2-atmel.0.99.2/LAST_UPDATED
---- gcc-4.0.2/LAST_UPDATED 2005-09-28 08:16:39.000000000 +0200
-+++ gcc-4.0.2-atmel.0.99.2/LAST_UPDATED 1970-01-01 01:00:00.000000000 +0100
-@@ -1 +0,0 @@
--Obtained from CVS: -rgcc_4_0_2_release
-Binary files gcc-4.0.2/libcpp/po/ca.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/ca.gmo differ
-Binary files gcc-4.0.2/libcpp/po/da.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/da.gmo differ
-Binary files gcc-4.0.2/libcpp/po/de.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/de.gmo differ
-Binary files gcc-4.0.2/libcpp/po/es.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/es.gmo differ
-Binary files gcc-4.0.2/libcpp/po/fr.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/fr.gmo differ
-Binary files gcc-4.0.2/libcpp/po/ja.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/ja.gmo differ
-Binary files gcc-4.0.2/libcpp/po/nl.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/nl.gmo differ
-Binary files gcc-4.0.2/libcpp/po/sv.gmo and gcc-4.0.2-atmel.0.99.2/libcpp/po/sv.gmo differ
diff -Nrup --ignore-space-change gcc-4.0.2/libcpp/po/sv.po gcc-4.0.2-atmel.0.99.2/libcpp/po/sv.po
--- gcc-4.0.2/libcpp/po/sv.po 2005-09-04 14:30:22.000000000 +0200
+++ gcc-4.0.2-atmel.0.99.2/libcpp/po/sv.po 2006-01-20 10:54:31.000000000 +0100
diff --git a/packages/gcc/gcc-cross_4.0.2.bb b/packages/gcc/gcc-cross_4.0.2.bb
index d2dc240126..59da2080e8 100644
--- a/packages/gcc/gcc-cross_4.0.2.bb
+++ b/packages/gcc/gcc-cross_4.0.2.bb
@@ -5,7 +5,7 @@ inherit cross
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
# NOTE: split PR. If the main .oe changes something that affects its *build*
# remember to increment this one too.
-PR = "r1"
+PR = "r7"
DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
diff --git a/packages/gcc/gcc_4.0.2.bb b/packages/gcc/gcc_4.0.2.bb
index bf886178b4..0541ddfe96 100644
--- a/packages/gcc/gcc_4.0.2.bb
+++ b/packages/gcc/gcc_4.0.2.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
LICENSE = "GPL"
DEPENDS = "mpfr gmp"
-PR = "r4"
+PR = "r5"
inherit autotools gettext