aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-06-02 21:35:01 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-06-02 21:35:01 +0000
commit001d9c598407b5be10622b238029a4fbfc88c5d1 (patch)
treeb9d4ef0c805ed6f9170ccb93f461e5bedfe0ca87 /packages/gcc
parent14ccfbe5dcdf312eb74384ef491c31ef57721072 (diff)
downloadopenembedded-001d9c598407b5be10622b238029a4fbfc88c5d1.tar.gz
gcc-cross-inital-4.3.0: fix DEPENDS
* in gcc-4.2 a missing gmp.h is just a warning in gcc-4.3.0 it is an error * gcc-cross-inital.inc is overwriting DEPENDS so gmp-native and mpfr-native from gcc-cross4.inc is not in DEPENDS for gcc-cross-initial * for now put in the .bb self, but someone should step up and fix the whole gcc-recipes in a saner way
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-cross-initial_4.3.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/gcc/gcc-cross-initial_4.3.0.bb b/packages/gcc/gcc-cross-initial_4.3.0.bb
index 7060d46758..c8738ad614 100644
--- a/packages/gcc/gcc-cross-initial_4.3.0.bb
+++ b/packages/gcc/gcc-cross-initial_4.3.0.bb
@@ -1,8 +1,11 @@
require gcc-cross_${PV}.bb
require gcc-cross-initial.inc
-EXTRA_OECONF += "--disable-libmudflap --disable-libgomp \
- --disable-libssp"
+DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF += " --disable-libmudflap \
+ --disable-libgomp \
+ --disable-libssp"
# Hack till we fix *libc properly
do_stage_append() {