aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2006-12-16 11:05:08 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-16 11:05:08 +0000
commita17cc3db3f7a2a218a018fd7295e21a6c9c09b2a (patch)
tree0e0a16ee18fddf2af2915c63a5769aea0afe9820 /packages/gcc
parentd8ca2edd0012372582b85d6b3f53962b5dd357b5 (diff)
downloadopenembedded-a17cc3db3f7a2a218a018fd7295e21a6c9c09b2a.tar.gz
gcc 4.1.1: add patch to fix PR 13685
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.1.1/gcc-4.1.1-pr13685-1.patch26
-rw-r--r--packages/gcc/gcc-cross_4.1.1.bb2
-rw-r--r--packages/gcc/gcc_4.1.1.bb5
3 files changed, 30 insertions, 3 deletions
diff --git a/packages/gcc/gcc-4.1.1/gcc-4.1.1-pr13685-1.patch b/packages/gcc/gcc-4.1.1/gcc-4.1.1-pr13685-1.patch
new file mode 100644
index 0000000000..a56b1307df
--- /dev/null
+++ b/packages/gcc/gcc-4.1.1/gcc-4.1.1-pr13685-1.patch
@@ -0,0 +1,26 @@
+Submitted By: Alexander E. Patrakov
+Date: 2006-12-11
+Initial Package Version: 4.1.1
+Upstream Status: backport
+Origin: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28621
+Description: Fix crash of programs compiled with -Os -ffast-math
+(affects procps on the LiveCD)
+--- gcc-4.1.1/gcc/config/i386/i386.c
++++ gcc-4.1.1/gcc/config/i386/i386.c
+@@ -1502,12 +1502,10 @@
+ }
+
+ /* Validate -mpreferred-stack-boundary= value, or provide default.
+- The default of 128 bits is for Pentium III's SSE __m128, but we
+- don't want additional code to keep the stack aligned when
+- optimizing for code size. */
+- ix86_preferred_stack_boundary = (optimize_size
+- ? TARGET_64BIT ? 128 : 32
+- : 128);
++ The default of 128 bits is for Pentium III's SSE __m128, We can't
++ change it because of optimize_size. Otherwise, we can't mix object
++ files compiled with -Os and -On. */
++ ix86_preferred_stack_boundary = 128;
+ if (ix86_preferred_stack_boundary_string)
+ {
+ i = atoi (ix86_preferred_stack_boundary_string);
diff --git a/packages/gcc/gcc-cross_4.1.1.bb b/packages/gcc/gcc-cross_4.1.1.bb
index 2f29e172a3..5721dee50b 100644
--- a/packages/gcc/gcc-cross_4.1.1.bb
+++ b/packages/gcc/gcc-cross_4.1.1.bb
@@ -5,7 +5,7 @@ inherit cross
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
# NOTE: split PR. If the main .oe changes something that affects its *build*
# remember to increment this one too.
-PR = "r8"
+PR = "r9"
DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index 81b81eebcd..e32353325a 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
@@ -30,7 +30,8 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://unbreak-armv4t.patch;patch=1 \
file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- "
+ file://gcc-4.1.1-pr13685-1.patch;patch=1 \
+ "
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "