aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-09-18 06:26:09 +0000
committerKhem Raj <raj.khem@gmail.com>2008-09-18 06:26:09 +0000
commitfb969b0c9475531e3b8dcd1d7fa4568bbe895e70 (patch)
treedffd37c78c33b5d042ed03752e2c218302e83dcf /packages/gcc
parenta7441008e144f91fecf79273a2118ea806552cf4 (diff)
downloadopenembedded-fb969b0c9475531e3b8dcd1d7fa4568bbe895e70.tar.gz
Fix the uclibc locale patch in gcc 4.3 for missing desctructor.
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.3.1/205-uclibc-locale-update.patch67
-rw-r--r--packages/gcc/gcc-4.3.2/205-uclibc-locale-update.patch67
-rw-r--r--packages/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--packages/gcc/gcc-cross-sdk_4.3.2.bb2
-rw-r--r--packages/gcc/gcc-cross_4.3.1.bb2
-rw-r--r--packages/gcc/gcc-cross_4.3.2.bb2
-rw-r--r--packages/gcc/gcc_4.3.1.bb2
-rw-r--r--packages/gcc/gcc_4.3.2.bb2
8 files changed, 82 insertions, 64 deletions
diff --git a/packages/gcc/gcc-4.3.1/205-uclibc-locale-update.patch b/packages/gcc/gcc-4.3.1/205-uclibc-locale-update.patch
index 8da7461145..48eaa1d442 100644
--- a/packages/gcc/gcc-4.3.1/205-uclibc-locale-update.patch
+++ b/packages/gcc/gcc-4.3.1/205-uclibc-locale-update.patch
@@ -1,7 +1,7 @@
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-08-19 02:52:48.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-09-17 22:35:29.000000000 -0700
@@ -39,23 +39,20 @@
#include <langinfo.h>
#include <bits/c++locale_internal.h>
@@ -122,10 +122,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc
-} // namespace std
+
+_GLIBCXX_END_NAMESPACE
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/ctype_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-08-19 02:12:04.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-09-17 23:09:49.000000000 -0700
@@ -33,16 +33,20 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -150,7 +150,16 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
ctype_byname<char>::ctype_byname(const char* __s, size_t __refs)
: ctype<char>(0, false, __refs)
{
-@@ -138,17 +142,33 @@
+@@ -57,6 +61,8 @@
+ #endif
+ }
+ }
++ ctype_byname<char>::~ctype_byname()
++ { }
+
+ #ifdef _GLIBCXX_USE_WCHAR_T
+ ctype<wchar_t>::__wmask_type
+@@ -138,17 +144,33 @@
ctype<wchar_t>::
do_is(mask __m, wchar_t __c) const
{
@@ -194,17 +203,17 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
return __ret;
}
-@@ -290,4 +310,5 @@
+@@ -290,4 +312,5 @@
#endif
}
#endif // _GLIBCXX_USE_WCHAR_T
-}
+
+_GLIBCXX_END_NAMESPACE
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/messages_members.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-08-19 03:00:38.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-09-17 23:13:34.000000000 -0700
@@ -53,12 +53,16 @@
template<typename _CharT>
messages<_CharT>::messages(__c_locale __cloc, const char* __s,
@@ -226,10 +235,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h
}
template<typename _CharT>
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/monetary_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-08-19 02:29:18.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -33,9 +33,14 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -323,10 +332,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc
#endif
}
}
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/numeric_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-08-19 01:41:34.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -33,9 +33,14 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -342,10 +351,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc
#include <bits/c++locale_internal.h>
#ifdef __UCLIBC_MJN3_ONLY__
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/time_members.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h 2008-08-19 03:00:38.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/time_members.h 2008-09-17 22:35:27.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.h 2008-09-17 23:13:34.000000000 -0700
@@ -50,12 +50,21 @@
__timepunct<_CharT>::__timepunct(__c_locale __cloc, const char* __s,
size_t __refs)
@@ -372,10 +381,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h
}
template<typename _CharT>
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-08-19 01:41:34.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-09-17 22:35:29.000000000 -0700
@@ -39,21 +39,23 @@
#pragma GCC system_header
@@ -454,10 +463,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h
#ifdef __UCLIBC_HAS_XCLOCALE__
__gnu_cxx::__uselocale(__old);
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-08-19 02:36:00.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-08-19 02:38:23.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -53,11 +53,14 @@
const size_t __len = __strftime_l(__s, __maxlen, __format, __tm,
_M_c_locale_timepunct);
@@ -494,10 +503,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc
#endif
// Make sure __s is null terminated.
if (__len == 0)
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c++locale_internal.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c++locale_internal.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-08-19 03:00:52.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-08-19 03:01:11.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-09-17 22:35:29.000000000 -0700
@@ -31,6 +31,9 @@
#include <bits/c++config.h>
diff --git a/packages/gcc/gcc-4.3.2/205-uclibc-locale-update.patch b/packages/gcc/gcc-4.3.2/205-uclibc-locale-update.patch
index 8da7461145..48eaa1d442 100644
--- a/packages/gcc/gcc-4.3.2/205-uclibc-locale-update.patch
+++ b/packages/gcc/gcc-4.3.2/205-uclibc-locale-update.patch
@@ -1,7 +1,7 @@
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-08-19 02:52:48.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.cc 2008-09-17 22:35:29.000000000 -0700
@@ -39,23 +39,20 @@
#include <langinfo.h>
#include <bits/c++locale_internal.h>
@@ -122,10 +122,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.cc
-} // namespace std
+
+_GLIBCXX_END_NAMESPACE
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/ctype_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-08-19 02:12:04.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/ctype_members.cc 2008-09-17 23:09:49.000000000 -0700
@@ -33,16 +33,20 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -150,7 +150,16 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
ctype_byname<char>::ctype_byname(const char* __s, size_t __refs)
: ctype<char>(0, false, __refs)
{
-@@ -138,17 +142,33 @@
+@@ -57,6 +61,8 @@
+ #endif
+ }
+ }
++ ctype_byname<char>::~ctype_byname()
++ { }
+
+ #ifdef _GLIBCXX_USE_WCHAR_T
+ ctype<wchar_t>::__wmask_type
+@@ -138,17 +144,33 @@
ctype<wchar_t>::
do_is(mask __m, wchar_t __c) const
{
@@ -194,17 +203,17 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/ctype_members.cc
return __ret;
}
-@@ -290,4 +310,5 @@
+@@ -290,4 +312,5 @@
#endif
}
#endif // _GLIBCXX_USE_WCHAR_T
-}
+
+_GLIBCXX_END_NAMESPACE
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/messages_members.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-08-19 03:00:38.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/messages_members.h 2008-09-17 23:13:34.000000000 -0700
@@ -53,12 +53,16 @@
template<typename _CharT>
messages<_CharT>::messages(__c_locale __cloc, const char* __s,
@@ -226,10 +235,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/messages_members.h
}
template<typename _CharT>
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/monetary_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-08-19 02:29:18.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/monetary_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -33,9 +33,14 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -323,10 +332,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/monetary_members.cc
#endif
}
}
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/numeric_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-08-19 01:41:34.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/numeric_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -33,9 +33,14 @@
// Written by Benjamin Kosnik <bkoz@redhat.com>
@@ -342,10 +351,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/numeric_members.cc
#include <bits/c++locale_internal.h>
#ifdef __UCLIBC_MJN3_ONLY__
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/time_members.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h 2008-08-19 03:00:38.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/time_members.h 2008-09-17 22:35:27.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.h 2008-09-17 23:13:34.000000000 -0700
@@ -50,12 +50,21 @@
__timepunct<_CharT>::__timepunct(__c_locale __cloc, const char* __s,
size_t __refs)
@@ -372,10 +381,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.h
}
template<typename _CharT>
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-08-19 01:41:34.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-08-19 01:41:34.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c_locale.h 2008-09-17 22:35:29.000000000 -0700
@@ -39,21 +39,23 @@
#pragma GCC system_header
@@ -454,10 +463,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c_locale.h
#ifdef __UCLIBC_HAS_XCLOCALE__
__gnu_cxx::__uselocale(__old);
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.cc
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-08-19 02:36:00.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-08-19 02:38:23.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/time_members.cc 2008-09-17 22:35:29.000000000 -0700
@@ -53,11 +53,14 @@
const size_t __len = __strftime_l(__s, __maxlen, __format, __tm,
_M_c_locale_timepunct);
@@ -494,10 +503,10 @@ Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/time_members.cc
#endif
// Make sure __s is null terminated.
if (__len == 0)
-Index: gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c++locale_internal.h
+Index: gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c++locale_internal.h
===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-08-19 03:00:52.000000000 -0700
-+++ gcc-4.3.1/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-08-19 03:01:11.000000000 -0700
+--- gcc-4.3.2.orig/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-09-17 22:35:28.000000000 -0700
++++ gcc-4.3.2/libstdc++-v3/config/locale/uclibc/c++locale_internal.h 2008-09-17 22:35:29.000000000 -0700
@@ -31,6 +31,9 @@
#include <bits/c++config.h>
diff --git a/packages/gcc/gcc-cross-sdk_4.3.1.bb b/packages/gcc/gcc-cross-sdk_4.3.1.bb
index 1c09b67716..93a33894ab 100644
--- a/packages/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/packages/gcc/gcc-cross-sdk_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "r11"
inherit sdk
diff --git a/packages/gcc/gcc-cross-sdk_4.3.2.bb b/packages/gcc/gcc-cross-sdk_4.3.2.bb
index 7f3e1466ce..7e3a459ea8 100644
--- a/packages/gcc/gcc-cross-sdk_4.3.2.bb
+++ b/packages/gcc/gcc-cross-sdk_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
inherit sdk
diff --git a/packages/gcc/gcc-cross_4.3.1.bb b/packages/gcc/gcc-cross_4.3.1.bb
index 2b93165d44..bfc8561a4c 100644
--- a/packages/gcc/gcc-cross_4.3.1.bb
+++ b/packages/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc-cross_4.3.2.bb b/packages/gcc/gcc-cross_4.3.2.bb
index 1220f8df0d..526ec1508b 100644
--- a/packages/gcc/gcc-cross_4.3.2.bb
+++ b/packages/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
diff --git a/packages/gcc/gcc_4.3.1.bb b/packages/gcc/gcc_4.3.1.bb
index c2fd8ccb21..4634820ff2 100644
--- a/packages/gcc/gcc_4.3.1.bb
+++ b/packages/gcc/gcc_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/packages/gcc/gcc_4.3.2.bb b/packages/gcc/gcc_4.3.2.bb
index 158469e988..ee926bd169 100644
--- a/packages/gcc/gcc_4.3.2.bb
+++ b/packages/gcc/gcc_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc