aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-02 10:44:14 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-02 10:44:14 +0100
commit478b4795357a146453d2fdcaf5451bf2f32b7252 (patch)
tree9f44df85fa66f7570b6537a1a9f4db996fa1e338 /packages/gcc
parenta9f44be1cbb357170617fcad211af0cd44063998 (diff)
downloadopenembedded-478b4795357a146453d2fdcaf5451bf2f32b7252.tar.gz
gcc: gcc 4.2.4 needs a different gfortran patch that 4.3.x
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.2.4/gfortran.patch40
-rw-r--r--packages/gcc/gcc-cross_4.2.4.bb2
2 files changed, 41 insertions, 1 deletions
diff --git a/packages/gcc/gcc-4.2.4/gfortran.patch b/packages/gcc/gcc-4.2.4/gfortran.patch
new file mode 100644
index 0000000000..96905e5d7d
--- /dev/null
+++ b/packages/gcc/gcc-4.2.4/gfortran.patch
@@ -0,0 +1,40 @@
+The patch below fixes a crash building libgfortran on arm-linux-gnueabi.
+
+This target doesn't really have a 128-bit integer type, however it does use
+TImode to represent the return value of certain special ABI defined library
+functions. This results in type_for_size(TImode) being called.
+
+Because TImode deosn't correspond to any gfortran integer kind
+gfc_type_for_size returns NULL and we segfault shortly after.
+
+The patch below fixes this by making gfc_type_for_size handle TImode in the
+same way as the C frontend.
+
+Tested on x86_64-linux and arm-linux-gnueabi.
+Applied to trunk.
+
+Paul
+
+2007-05-15 Paul Brook <paul@codesourcery.com>
+
+ gcc/fortran/
+ * trans-types.c (gfc_type_for_size): Handle signed TImode.
+
+Index: gcc-4.2.1/gcc/fortran/trans-types.c
+===================================================================
+--- gcc-4.2.1/gcc/fortran/trans-types.c (revision 170435)
++++ gcc-4.2.1/gcc/fortran/trans-types.c (working copy)
+@@ -1800,6 +1800,13 @@ gfc_type_for_size (unsigned bits, int un
+ if (type && bits == TYPE_PRECISION (type))
+ return type;
+ }
++
++ /* Handle TImode as a special case because it is used by some backends
++ (eg. ARM) even though it is not available for normal use. */
++#if HOST_BITS_PER_WIDE_INT >= 64
++ if (bits == TYPE_PRECISION (intTI_type_node))
++ return intTI_type_node;
++#endif
+ }
+ else
+ {
diff --git a/packages/gcc/gcc-cross_4.2.4.bb b/packages/gcc/gcc-cross_4.2.4.bb
index cac2550f0e..f51e60ce13 100644
--- a/packages/gcc/gcc-cross_4.2.4.bb
+++ b/packages/gcc/gcc-cross_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
require gcc-${PV}.inc
require gcc-cross4.inc