aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-10-06 19:14:33 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-10-06 19:14:33 +0000
commit821b74d1c59559496ed7e7e86531fe3f76f4dade (patch)
tree69be8059dac5ea2519e4f92017bc42cc8ede31a0 /packages/gcc
parent2edf230ed11e823ca4ecad9c7ae837cabba8fef2 (diff)
downloadopenembedded-821b74d1c59559496ed7e7e86531fe3f76f4dade.tar.gz
gcc-4.3.2: use multilib on sh4, so kernel can compile without fpu
registers * add patch gcc-4.2.3-linux-multilib-fix.patch used by various other linux distributions * put the mulitlib config in gcc-cross4.inc because gcc-3 works without that * need to bump PR because we pushed in earlier changes on sh4 without bumping
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.3.2.inc2
-rw-r--r--packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch23
-rw-r--r--packages/gcc/gcc-cross4.inc2
-rw-r--r--packages/gcc/gcc-cross_4.3.2.bb2
4 files changed, 27 insertions, 2 deletions
diff --git a/packages/gcc/gcc-4.3.2.inc b/packages/gcc/gcc-4.3.2.inc
index 21c08ffccc..74ed254694 100644
--- a/packages/gcc/gcc-4.3.2.inc
+++ b/packages/gcc/gcc-4.3.2.inc
@@ -60,8 +60,8 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
SRC_URI_append_sh4 = " file://sh_unwind.patch;patch=1 \
+ file://gcc-4.2.3-linux-multilib-fix.patch;patch=1 \
"
-
# Language Overrides
FORTRAN = ""
JAVA = ""
diff --git a/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch b/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch
new file mode 100644
index 0000000000..81522a8f57
--- /dev/null
+++ b/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch
@@ -0,0 +1,23 @@
+Change gcc build : Enable m4 and m4-nofpu (needed for kernel) for sh4-gnu-linux
+
+Signed-off-by: Carl Shaw <carl.shaw@st.com>
+
+Index: gcc/gcc/config.gcc
+===================================================================
+--- gcc.orig/gcc/config.gcc 2008-07-18 10:37:54.000000000 +0100
++++ gcc/gcc/config.gcc 2008-07-18 11:00:42.000000000 +0100
+@@ -2097,11 +2097,12 @@
+ if test x${sh_multilibs} = x ; then
+ case ${target} in
+ sh64-superh-linux* | \
+- sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ sh64* | sh5*) sh_multilibs=m5-32media,m5-32media-nofpu,m5-compact,m5-compact-nofpu,m5-64media,m5-64media-nofpu ;;
+- sh-superh-*) sh_multilibs=m4,m4-single,m4-single-only,m4-nofpu ;;
++ sh-superh-* | \
++ sh4-*-linux*) sh_multilibs=m4,m4-nofpu ;;
+ sh*-*-linux*) sh_multilibs=m1,m3e,m4 ;;
+ sh*-*-netbsd*) sh_multilibs=m3,m3e,m4 ;;
++ sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ *) sh_multilibs=m1,m2,m2e,m4,m4-single,m4-single-only,m2a,m2a-single ;;
+ esac
+ if test x$with_fp = xno; then
diff --git a/packages/gcc/gcc-cross4.inc b/packages/gcc/gcc-cross4.inc
index 3d3403737a..77a55968fa 100644
--- a/packages/gcc/gcc-cross4.inc
+++ b/packages/gcc/gcc-cross4.inc
@@ -1,3 +1,5 @@
require gcc-cross.inc
DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF_append_sh4 = " --with-multilib-list=m4,m4-nofpu "
diff --git a/packages/gcc/gcc-cross_4.3.2.bb b/packages/gcc/gcc-cross_4.3.2.bb
index 526ec1508b..18d5abd32e 100644
--- a/packages/gcc/gcc-cross_4.3.2.bb
+++ b/packages/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc