aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-02-16 17:26:44 -0500
committerTom Rini <trini@embeddedalley.com>2009-02-16 17:26:44 -0500
commit957e3d34d286c9b1a38be03cda2f64f483d4cb82 (patch)
tree0c2a76f9df40267c6d7cf16740552b5938969653 /packages/gcc
parentab6ba812119aa2fbd9c14a5fd7dc0cca63ed5a12 (diff)
downloadopenembedded-957e3d34d286c9b1a38be03cda2f64f483d4cb82.tar.gz
gcc-canadian-sdk: Fix a problem where we were passing the wrong headers and such as the target ones.
We were accidentially using (and shipping) mingw headers instead of the target ones.
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-canadian-sdk_4.2.4.bb9
-rw-r--r--packages/gcc/gcc-configure-canadian-sdk.inc13
2 files changed, 7 insertions, 15 deletions
diff --git a/packages/gcc/gcc-canadian-sdk_4.2.4.bb b/packages/gcc/gcc-canadian-sdk_4.2.4.bb
index 03d9ae364a..ae3245bf7f 100644
--- a/packages/gcc/gcc-canadian-sdk_4.2.4.bb
+++ b/packages/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -17,13 +17,8 @@ require gcc-package-canadian-sdk.inc
SRC_URI_append = "file://fortran-cross-compile-hack.patch;patch=1 \
file://pr22133-mingw-path-fixup.patch;patch=1 \
file://pr33281-mingw-host-fragment.patch;patch=1 \
- file://pr35916-mingw-__USE_MINGW_ACCESS-everywhere.patch;patch=1"
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
-
-
-SRC_URI_append =+ "\
- file://canadian-build-modules-configure.patch;patch=1 \
+ file://pr35916-mingw-__USE_MINGW_ACCESS-everywhere.patch;patch=1 \
+ file://canadian-build-modules-configure.patch;patch=1 \
"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
diff --git a/packages/gcc/gcc-configure-canadian-sdk.inc b/packages/gcc/gcc-configure-canadian-sdk.inc
index 489cb46371..c95a6c41df 100644
--- a/packages/gcc/gcc-configure-canadian-sdk.inc
+++ b/packages/gcc/gcc-configure-canadian-sdk.inc
@@ -3,7 +3,10 @@ require gcc-configure-common.inc
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
-ARCH_FLAGS_FOR_TARGET=""
+#
+# We need to override this and make sure the compiler can find staging
+#
+export ARCH_FLAGS_FOR_TARGET = "--sysroot=${STAGING_DIR_TARGET}"
# Tools for build
export CC_FOR_BUILD="${BUILD_CC}"
@@ -57,22 +60,16 @@ export WINDRES_FOR_TARGET="${TARGET_PREFIX}windres"
EXTRA_OECONF_DEP ?= ""
-SYSROOT = "${WORKDIR}/sysroot"
EXTRA_OECONF += ""
EXTRA_OECONF_PATHS = " \
--with-local-prefix=$dollar{prefix}/local \
--with-gxx-include-dir=$dollar{prefix}/${TARGET_SYS}/usr/include/c++/${BINV} \
- --with-build-sysroot=${SYSROOT} \
+ --with-build-sysroot=${STAGING_DIR_TARGET} \
--with-sysroot=${SDK_REALPATH}/${TARGET_SYS} \
"
do_configure () {
# Work around Hardcoded path assumptions in gcc
- mkdir -p ${SYSROOT}/usr
- ln -sf ${STAGING_DIR_HOST}${layout_includedir} \
- ${SYSROOT}/usr/include
- ln -sf ${STAGING_DIR_HOST}${layout_libdir} \
- ${SYSROOT}/usr/lib
(cd ${S} && gnu-configize) || die "failure running gnu-configize"
(cd ${S}/libstdc++-v3 && autoreconf)
canadian_sdk_runconf