aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-06 11:45:56 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-06 11:45:56 +0000
commitb8d1ef0e4fb7c506a5c0de055a276159049df948 (patch)
treeda934a76e83ee9c8ddac03bbabc3d609567f3c94 /packages/gcc
parent44b1ddb504535400e1272d5d9259778249f36b47 (diff)
downloadopenembedded-b8d1ef0e4fb7c506a5c0de055a276159049df948.tar.gz
packages/gcc: For targets (libstdc++,java,mudflap...) use xgcc -E as CPP
GCC compiles the xgcc cross compiler and will compile target libraries e.g. libstdc++. It uses autoconf to configure the target libraries which uses /usr/bin/cpp to determine the presence of host includes. By using xgcc we will not risk to include /usr/include to find standard headers. If we do our cross compile check will hit. The gcc 3.4 series patch only addresses target-libstdc++ where the gcc3.3 and gcc4 series patch all targets
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-3.3.3/zecke-xgcc-cpp.patch13
-rw-r--r--packages/gcc/gcc-3.3.4/zecke-xgcc-cpp.patch13
-rw-r--r--packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch16
-rw-r--r--packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch13
-rw-r--r--packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc-4.1-20060217/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc-4.1.0/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch12
-rw-r--r--packages/gcc/gcc_3.3.3.bb1
-rw-r--r--packages/gcc/gcc_3.3.4.bb1
-rw-r--r--packages/gcc/gcc_3.4.3.bb3
-rw-r--r--packages/gcc/gcc_3.4.4.bb3
-rw-r--r--packages/gcc/gcc_4.0.0.bb1
-rw-r--r--packages/gcc/gcc_4.0.2.bb3
-rw-r--r--packages/gcc/gcc_4.1-20060217.bb1
-rw-r--r--packages/gcc/gcc_4.1.0.bb1
-rw-r--r--packages/gcc/gcc_4.1.1.bb3
-rw-r--r--packages/gcc/gcc_4.2-20060513.bb1
20 files changed, 141 insertions, 4 deletions
diff --git a/packages/gcc/gcc-3.3.3/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.3.3/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..d12562761f
--- /dev/null
+++ b/packages/gcc/gcc-3.3.3/zecke-xgcc-cpp.patch
@@ -0,0 +1,13 @@
+Index: gcc-3.3.3/Makefile.in
+===================================================================
+--- gcc-3.3.3.orig/Makefile.in 2003-07-05 04:37:08.000000000 +0200
++++ gcc-3.3.3/Makefile.in 2006-08-06 12:57:53.000000000 +0200
+@@ -1355,6 +1355,8 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
++ CPPFLAGS=""; export CPPFLAGS; \
+ CXX="$(CXX_FOR_TARGET)"; export CXX; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
+ GCJ="$(GCJ_FOR_TARGET)"; export GCJ; \
diff --git a/packages/gcc/gcc-3.3.4/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.3.4/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..d42ab6d57d
--- /dev/null
+++ b/packages/gcc/gcc-3.3.4/zecke-xgcc-cpp.patch
@@ -0,0 +1,13 @@
+Index: gcc-3.3.4/Makefile.in
+===================================================================
+--- gcc-3.3.4.orig/Makefile.in 2003-07-05 04:37:08.000000000 +0200
++++ gcc-3.3.4/Makefile.in 2006-08-06 13:00:16.000000000 +0200
+@@ -1355,6 +1355,8 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
++ CPPFLAGS=""; export CPPFLAGS; \
+ CXX="$(CXX_FOR_TARGET)"; export CXX; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
+ GCJ="$(GCJ_FOR_TARGET)"; export GCJ; \
diff --git a/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..08e7a3124d
--- /dev/null
+++ b/packages/gcc/gcc-3.4.3/zecke-xgcc-cpp.patch
@@ -0,0 +1,16 @@
+In contrast to the other versions this only patches libstdc++
+
+
+Index: gcc-3.4.3/Makefile.in
+===================================================================
+--- gcc-3.4.3.orig/Makefile.in 2004-11-05 05:14:05.000000000 +0100
++++ gcc-3.4.3/Makefile.in 2006-08-06 13:03:37.000000000 +0200
+@@ -21964,6 +21964,8 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPPFLAGS=""; export CPPFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXX_FOR_TARGET="$(RAW_CXX_FOR_TARGET)"; export CXX_FOR_TARGET; \
diff --git a/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch b/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..ab6a3fd771
--- /dev/null
+++ b/packages/gcc/gcc-3.4.4/zecke-xgcc-cpp.patch
@@ -0,0 +1,13 @@
+Index: gcc-3.4.4/Makefile.in
+===================================================================
+--- gcc-3.4.4.orig/Makefile.in 2005-05-19 11:58:00.000000000 +0200
++++ gcc-3.4.4/Makefile.in 2006-08-06 13:08:14.000000000 +0200
+@@ -21964,6 +21964,8 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
++ CPPFLAGS=""; export CPPFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXX_FOR_TARGET="$(RAW_CXX_FOR_TARGET)"; export CXX_FOR_TARGET; \
diff --git a/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..436eff02ae
--- /dev/null
+++ b/packages/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.0.0/Makefile.in
+===================================================================
+--- gcc-4.0.0.orig/Makefile.in 2005-04-21 09:04:10.000000000 +0200
++++ gcc-4.0.0/Makefile.in 2006-08-06 13:14:07.000000000 +0200
+@@ -197,6 +197,7 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..ba7d7257d9
--- /dev/null
+++ b/packages/gcc/gcc-4.0.2/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.0.2/Makefile.in
+===================================================================
+--- gcc-4.0.2.orig/Makefile.in 2006-08-06 13:17:09.000000000 +0200
++++ gcc-4.0.2/Makefile.in 2006-08-06 13:18:35.000000000 +0200
+@@ -197,6 +197,7 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.1-20060217/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1-20060217/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..8b53f653c6
--- /dev/null
+++ b/packages/gcc/gcc-4.1-20060217/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.1-20060217/Makefile.in
+===================================================================
+--- gcc-4.1-20060217.orig/Makefile.in 2005-12-15 15:02:02.000000000 +0100
++++ gcc-4.1-20060217/Makefile.in 2006-08-06 13:23:23.000000000 +0200
+@@ -194,6 +194,7 @@
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.1.0/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.0/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..120cf55a0f
--- /dev/null
+++ b/packages/gcc/gcc-4.1.0/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.1.0/Makefile.in
+===================================================================
+--- gcc-4.1.0.orig/Makefile.in 2005-12-15 15:02:02.000000000 +0100
++++ gcc-4.1.0/Makefile.in 2006-08-06 13:29:36.000000000 +0200
+@@ -194,6 +194,7 @@
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..42ec190600
--- /dev/null
+++ b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.1.1/Makefile.in
+===================================================================
+--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
++++ gcc-4.1.1/Makefile.in 2006-08-06 13:32:46.000000000 +0200
+@@ -194,6 +194,7 @@
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..ba7d7257d9
--- /dev/null
+++ b/packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.0.2/Makefile.in
+===================================================================
+--- gcc-4.0.2.orig/Makefile.in 2006-08-06 13:17:09.000000000 +0200
++++ gcc-4.0.2/Makefile.in 2006-08-06 13:18:35.000000000 +0200
+@@ -197,6 +197,7 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc_3.3.3.bb b/packages/gcc/gcc_3.3.3.bb
index 7f0091a18e..f46c481f69 100644
--- a/packages/gcc/gcc_3.3.3.bb
+++ b/packages/gcc/gcc_3.3.3.bb
@@ -93,6 +93,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gcc-uclibc-3.3-110-conf.patch;patch=1 \
file://gcc-uclibc-3.3-120-softfloat.patch;patch=1 \
file://gcc-uclibc-3.3-200-code.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://bash3.patch;patch=1"
MIRRORS_prepend () {
diff --git a/packages/gcc/gcc_3.3.4.bb b/packages/gcc/gcc_3.3.4.bb
index dc3a66cd29..4a1d146dbb 100644
--- a/packages/gcc/gcc_3.3.4.bb
+++ b/packages/gcc/gcc_3.3.4.bb
@@ -70,6 +70,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gcc-uclibc-3.3-110-conf.patch;patch=1 \
file://gcc-uclibc-3.3-120-softfloat.patch;patch=1 \
file://gcc-uclibc-3.3-200-code.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://bash3.patch;patch=1"
PREMIRRORS_prepend () {
diff --git a/packages/gcc/gcc_3.4.3.bb b/packages/gcc/gcc_3.4.3.bb
index c7c6d3e8c9..906465b1a9 100644
--- a/packages/gcc/gcc_3.4.3.bb
+++ b/packages/gcc/gcc_3.4.3.bb
@@ -23,6 +23,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://GCC3.4.0VisibilityPatch.diff;patch=1 \
file://15342.patch;patch=1 \
file://always-fixincperm.patch;patch=1 \
- file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1"
+ file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
require gcc3-build.inc
diff --git a/packages/gcc/gcc_3.4.4.bb b/packages/gcc/gcc_3.4.4.bb
index 144852f15a..fece12cab0 100644
--- a/packages/gcc/gcc_3.4.4.bb
+++ b/packages/gcc/gcc_3.4.4.bb
@@ -23,7 +23,8 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://GCC3.4.0VisibilityPatch.diff;patch=1 \
file://15342.patch;patch=1 \
file://always-fixincperm.patch;patch=1 \
- file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1"
+ file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
SRC_URI += "file://gcc34-configure.in.patch;patch=1"
SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
diff --git a/packages/gcc/gcc_4.0.0.bb b/packages/gcc/gcc_4.0.0.bb
index 0c708984c0..cf9d704c45 100644
--- a/packages/gcc/gcc_4.0.0.bb
+++ b/packages/gcc/gcc_4.0.0.bb
@@ -10,6 +10,7 @@ inherit autotools gettext
require gcc-package.inc
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://ldflags.patch;patch=1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/packages/gcc/gcc_4.0.2.bb b/packages/gcc/gcc_4.0.2.bb
index b5b85a983f..73ff96e28c 100644
--- a/packages/gcc/gcc_4.0.2.bb
+++ b/packages/gcc/gcc_4.0.2.bb
@@ -14,7 +14,8 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
file://ldflags.patch;patch=1 \
- file://GCOV_PREFIX_STRIP-cross-profile_4.1.patch;patch=1"
+ file://GCOV_PREFIX_STRIP-cross-profile_4.1.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
# uclibc patches below
SRC_URI_append = " file://100-uclibc-conf.patch;patch=1 \
diff --git a/packages/gcc/gcc_4.1-20060217.bb b/packages/gcc/gcc_4.1-20060217.bb
index bcd9e9f235..6889f04a36 100644
--- a/packages/gcc/gcc_4.1-20060217.bb
+++ b/packages/gcc/gcc_4.1-20060217.bb
@@ -12,6 +12,7 @@ require gcc-package.inc
SRC_URI = "http://ftp.nluug.nl/languages/gcc/snapshots/4.1-20060217/gcc-4.1-20060217.tar.bz2 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://ldflags.patch;patch=1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/packages/gcc/gcc_4.1.0.bb b/packages/gcc/gcc_4.1.0.bb
index 80a4b89d7c..862a1dfe5b 100644
--- a/packages/gcc/gcc_4.1.0.bb
+++ b/packages/gcc/gcc_4.1.0.bb
@@ -12,6 +12,7 @@ require gcc-package.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.0/gcc-4.1.0.tar.bz2 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://ldflags.patch;patch=1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index 17367b67d4..e2d3d25ea8 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -26,7 +26,8 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
file://arm-thumb.patch;patch=1 \
file://arm-thumb-cache.patch;patch=1 \
file://ldflags.patch;patch=1 \
- file://cse.patch;patch=1"
+ file://cse.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/packages/gcc/gcc_4.2-20060513.bb b/packages/gcc/gcc_4.2-20060513.bb
index 5b68fb254b..8960469a18 100644
--- a/packages/gcc/gcc_4.2-20060513.bb
+++ b/packages/gcc/gcc_4.2-20060513.bb
@@ -12,6 +12,7 @@ require gcc-package.inc
SRC_URI = "http://ftp.nluug.nl/languages/gcc/snapshots/${PV}/gcc-${PV}.tar.bz2 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
file://ldflags.patch;patch=1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "