aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2008-10-18 09:13:33 +0100
committerPhil Blundell <philb@gnu.org>2008-10-18 09:13:33 +0100
commitc6aff25fcf987b04ec654b4331dcded4eae27696 (patch)
tree9b6c316f916cde1b4c1997d70a91d6659b9f0fca /packages/gcc
parent3607c5935c4408e281ea4ca7706719ab694d51f1 (diff)
downloadopenembedded-c6aff25fcf987b04ec654b4331dcded4eae27696.tar.gz
gcc-4.1.1: fix problem with backslash in sed command
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.1.1.inc1
-rw-r--r--packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.1.1.inc b/packages/gcc/gcc-4.1.1.inc
index 92ee2d7bb8..ac8a4a8a71 100644
--- a/packages/gcc/gcc-4.1.1.inc
+++ b/packages/gcc/gcc-4.1.1.inc
@@ -29,6 +29,7 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
file://gcc-ignore-cache.patch;patch=1 \
file://gcc-4.1.1-e300cx.patch;patch=1 \
file://pr34130.patch;patch=1 \
+ file://sed-fixinc-backslash.patch;patch=1 \
"
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch b/packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
new file mode 100644
index 0000000000..9aff951bdc
--- /dev/null
+++ b/packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
@@ -0,0 +1,18 @@
+2006-09-06 Matthias Klose <doko@debian.org>
+
+ * Makefile.in (s-macro_list): Conform to POSIX rules in single quoted
+ strings.
+
+--- s/gcc/Makefile.in~ 2008-10-18 08:53:56.000000000 +0100
++++ s/gcc/Makefile.in 2008-10-18 08:55:16.000000000 +0100
+@@ -3146,8 +3146,8 @@
+ macro_list: s-macro_list; @true
+ s-macro_list : $(GCC_PASSES)
+ echo | $(GCC_FOR_TARGET) -E -dM - | \
+- sed -n 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p ; \
+- s/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
++ sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
++ -e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
+ sort -u > tmp-macro_list
+ $(SHELL) $(srcdir)/../move-if-change tmp-macro_list macro_list
+ $(STAMP) s-macro_list