aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-11-14 15:33:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-14 15:33:41 +0000
commit401c2566de3debb224b44fdec8d878b2c83738f2 (patch)
treee547208bbd4107d26261b6b420680677dc835600 /packages/gcc
parent824295f3609d4c5e76ca153756e41406d81f0534 (diff)
downloadopenembedded-401c2566de3debb224b44fdec8d878b2c83738f2.tar.gz
gcc: Add version 4.0.2. Known to at least compile code on softfloat arm.
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.0.2/.mtn2git_empty0
-rw-r--r--packages/gcc/gcc-4.0.2/arm-nolibfloat.patch24
-rw-r--r--packages/gcc/gcc-4.0.2/arm-softfloat.patch16
-rw-r--r--packages/gcc/gcc-4.0.2/ldflags.patch22
-rw-r--r--packages/gcc/gcc-cross_4.0.2.bb16
-rw-r--r--packages/gcc/gcc_4.0.2.bb19
6 files changed, 97 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.0.2/.mtn2git_empty b/packages/gcc/gcc-4.0.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gcc/gcc-4.0.2/.mtn2git_empty
diff --git a/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch b/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch
new file mode 100644
index 0000000000..c4897c0330
--- /dev/null
+++ b/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch
@@ -0,0 +1,24 @@
+# Dimitry Andric <dimitry@andric.com>, 2004-05-01
+#
+# * Removed the extra -lfloat option from LIBGCC_SPEC, since it isn't needed
+# anymore. (The required functions are now in libgcc.)
+#
+# Fixes errors like
+# arm-softfloat-linux-gnu/3.4.0/../../../../arm-softfloat-linux-gnu/bin/ld: cannot find -lfloat
+# collect2: ld returned 1 exit status
+# make[2]: *** [arm-softfloat-linux-gnu/gcc-3.4.0-glibc-2.3.2/build-glibc/iconvdata/ISO8859-1.so] Error 1
+# when building glibc-2.3.3 with gcc-3.4.0 for arm-softfloat
+
+Index: gcc-4.0.2/gcc/config/arm/linux-elf.h
+===================================================================
+--- gcc-4.0.2.orig/gcc/config/arm/linux-elf.h 2005-03-04 16:14:01.000000000 +0000
++++ gcc-4.0.2/gcc/config/arm/linux-elf.h 2005-11-11 18:02:54.000000000 +0000
+@@ -56,7 +56,7 @@
+ %{shared:-lc} \
+ %{!shared:%{profile:-lc_p}%{!profile:-lc}}"
+
+-#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
++#define LIBGCC_SPEC "-lgcc"
+
+ /* Provide a STARTFILE_SPEC appropriate for GNU/Linux. Here we add
+ the GNU/Linux magical crtbegin.o file (see crtstuff.c) which
diff --git a/packages/gcc/gcc-4.0.2/arm-softfloat.patch b/packages/gcc/gcc-4.0.2/arm-softfloat.patch
new file mode 100644
index 0000000000..c86c83ed15
--- /dev/null
+++ b/packages/gcc/gcc-4.0.2/arm-softfloat.patch
@@ -0,0 +1,16 @@
+Index: gcc-4.0.2/gcc/config/arm/t-linux
+===================================================================
+--- gcc-4.0.2.orig/gcc/config/arm/t-linux 2004-05-15 12:41:35.000000000 +0000
++++ gcc-4.0.2/gcc/config/arm/t-linux 2005-11-11 16:07:53.000000000 +0000
+@@ -4,7 +4,10 @@
+ LIBGCC2_DEBUG_CFLAGS = -g0
+
+ LIB1ASMSRC = arm/lib1funcs.asm
+-LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx
++LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx \
++ _negdf2 _addsubdf3 _muldivdf3 _cmpdf2 _unorddf2 _fixdfsi _fixunsdfsi \
++ _truncdfsf2 _negsf2 _addsubsf3 _muldivsf3 _cmpsf2 _unordsf2 \
++ _fixsfsi _fixunssfsi _floatdidf _floatdisf
+
+ # MULTILIB_OPTIONS = mhard-float/msoft-float
+ # MULTILIB_DIRNAMES = hard-float soft-float
diff --git a/packages/gcc/gcc-4.0.2/ldflags.patch b/packages/gcc/gcc-4.0.2/ldflags.patch
new file mode 100644
index 0000000000..1196bf0c8e
--- /dev/null
+++ b/packages/gcc/gcc-4.0.2/ldflags.patch
@@ -0,0 +1,22 @@
+--- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
++++ gcc-4.0.0/Makefile.tpl 2005-06-10 13:05:10.000000000 +0100
+@@ -339,7 +339,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+
+--- gcc-4.0.0/Makefile.in.old 2005-06-10 17:13:12.000000000 +0100
++++ gcc-4.0.0/Makefile.in 2005-06-10 17:13:22.000000000 +0100
+@@ -336,7 +336,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+
diff --git a/packages/gcc/gcc-cross_4.0.2.bb b/packages/gcc/gcc-cross_4.0.2.bb
new file mode 100644
index 0000000000..6e299e8299
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.0.2.bb
@@ -0,0 +1,16 @@
+include gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-build-cross.inc
+# cross packaging
+include gcc-package-cross.inc
diff --git a/packages/gcc/gcc_4.0.2.bb b/packages/gcc/gcc_4.0.2.bb
new file mode 100644
index 0000000000..856809a7bb
--- /dev/null
+++ b/packages/gcc/gcc_4.0.2.bb
@@ -0,0 +1,19 @@
+PR = "r1"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
+
+DEFAULT_PREFERENCE_nslu2 = "-1"
+
+inherit autotools gettext
+
+include gcc-package.inc
+
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://arm-nolibfloat.patch;patch=1 \
+ file://arm-softfloat.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+
+include gcc4-build.inc