aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-26 10:19:23 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-26 10:19:23 +0000
commit09aa8d4da8dbc59b2abaf82d48ca75cdab874111 (patch)
tree1e7376bc6efb780aec7b8e83af05d2ed48cfe214 /packages/gcc
parent8050b45254a8f36b7873b2d9027d2fe902e79a87 (diff)
downloadopenembedded-09aa8d4da8dbc59b2abaf82d48ca75cdab874111.tar.gz
gcc 4.1.1: Add patch from Dallas Foley to fix EABI on armv4t
* no more 'clz' isns in binaries
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.1.1/unbreak-armv4t.patch12
-rw-r--r--packages/gcc/gcc_4.1.1.bb4
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/gcc/gcc-4.1.1/unbreak-armv4t.patch b/packages/gcc/gcc-4.1.1/unbreak-armv4t.patch
new file mode 100644
index 0000000000..b3399abfdb
--- /dev/null
+++ b/packages/gcc/gcc-4.1.1/unbreak-armv4t.patch
@@ -0,0 +1,12 @@
+diff -urN gcc-4.1.1/gcc/config/arm/linux-eabi.h gcc-4.1.1-arm9tdmi/gcc/config/arm/linux-eabi.h
+--- gcc-4.1.1/gcc/config/arm/linux-eabi.h 2006-10-22 11:11:49.000000000 -0700
++++ gcc-4.1.1-arm9tdmi/gcc/config/arm/linux-eabi.h 2006-10-24 21:34:01.000000000 -0700
+@@ -45,7 +45,7 @@
+ The ARM10TDMI core is the default for armv5t, so set
+ SUBTARGET_CPU_DEFAULT to achieve this. */
+ #undef SUBTARGET_CPU_DEFAULT
+-#define SUBTARGET_CPU_DEFAULT TARGET_CPU_arm10tdmi
++#define SUBTARGET_CPU_DEFAULT TARGET_CPU_arm9tdmi
+
+ #undef SUBTARGET_EXTRA_LINK_SPEC
+ #define SUBTARGET_EXTRA_LINK_SPEC " -m armelf_linux_eabi"
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index e2d3d25ea8..7d61c22a9e 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -27,7 +27,9 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
file://arm-thumb-cache.patch;patch=1 \
file://ldflags.patch;patch=1 \
file://cse.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 "
+ file://zecke-xgcc-cpp.patch;patch=1 \
+ file://unbreak-armv4t.patch;patch=1 \
+ "
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "