aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-06-04 17:34:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-04 17:34:37 +0000
commit54078b3a619a01f9dd55386bc92e775723941f1c (patch)
tree18d9c69a9379efee01679764b7319c044dd902cc /packages/gcc
parentfd20b78f0215098dea16c536e056f2c977bfd35d (diff)
downloadopenembedded-54078b3a619a01f9dd55386bc92e775723941f1c.tar.gz
gcc 4.1.1: added patch for big endian
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.1.1/armeb-fix.patch38
-rw-r--r--packages/gcc/gcc-cross_4.1.1.bb2
-rw-r--r--packages/gcc/gcc_4.1.1.bb3
3 files changed, 24 insertions, 19 deletions
diff --git a/packages/gcc/gcc-4.1.1/armeb-fix.patch b/packages/gcc/gcc-4.1.1/armeb-fix.patch
index 42bb4ea9ab..2c22f28e41 100644
--- a/packages/gcc/gcc-4.1.1/armeb-fix.patch
+++ b/packages/gcc/gcc-4.1.1/armeb-fix.patch
@@ -1,6 +1,6 @@
--- gcc-4.0-20050305/gcc/config/arm/linux-elf.h.orig 2005-03-23 18:44:54.822707377 +0100
+++ gcc-4.0-20050305/gcc/config/arm/linux-elf.h 2005-03-23 18:46:18.228560206 +0100
-@@ -31,19 +31,33 @@
+@@ -28,19 +28,35 @@
/* Do not assume anything about header files. */
#define NO_IMPLICIT_EXTERN_C
@@ -9,11 +9,13 @@
+ * arm*b-*-linux* (big endian) configurations.
+ */
+#if TARGET_BIG_ENDIAN_DEFAULT
-+#define TARGET_ENDIAN_DEFAULT ARM_FLAG_BIG_END
++#define TARGET_ENDIAN_DEFAULT 1
++#define TARGET_BIG_END 1
+#define TARGET_ENDIAN_OPTION "mbig-endian"
+#define TARGET_LINKER_EMULATION "armelfb_linux"
+#else
+#define TARGET_ENDIAN_DEFAULT 0
++#define TARGET_BIG_END 0
+#define TARGET_ENDIAN_OPTION "mlittle-endian"
+#define TARGET_LINKER_EMULATION "armelf_linux"
+#endif
@@ -37,7 +39,7 @@
/* The GNU C++ standard library requires that these macros be defined. */
#undef CPLUSPLUS_CPP_SPEC
-@@ -90,7 +104,7 @@
+@@ -90,7 +75,7 @@
%{rdynamic:-export-dynamic} \
%{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2} \
-X \
@@ -46,17 +48,19 @@
SUBTARGET_EXTRA_LINK_SPEC
#define TARGET_OS_CPP_BUILTINS() \
---- gcc-4.0-20050305/gcc/config.gcc.orig 2005-03-23 18:46:23.318105335 +0100
-+++ gcc-4.0-20050305/gcc/config.gcc 2005-03-23 18:47:41.592546386 +0100
-@@ -650,6 +650,11 @@
- ;;
- arm*-*-linux*) # ARM GNU/Linux with ELF
- tm_file="dbxelf.h elfos.h linux.h arm/elf.h arm/linux-gas.h arm/linux-elf.h arm/aout.h arm/arm.h"
-+ case $target in
-+ arm*b-*-linux*)
-+ tm_defines="${tm_defines} TARGET_BIG_ENDIAN_DEFAULT=1"
-+ ;;
-+ esac
- tmake_file="${tmake_file} arm/t-arm arm/t-linux"
- extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
- gnu_ld=yes
+*** gcc/gcc/config.gcc.orig 2006-06-04 17:59:06.000000000 +0200
+--- gcc/gcc/config.gcc 2006-06-04 17:59:52.000000000 +0200
+***************
+*** 672,677 ****
+--- 672,682 ----
+ ;;
+ arm*-*-linux*) # ARM GNU/Linux with ELF
+ tm_file="dbxelf.h elfos.h linux.h arm/elf.h arm/linux-gas.h arm/linux-elf.h"
++ case $target in
++ arm*b-*-linux*)
++ tm_defines="${tm_defines} TARGET_BIG_ENDIAN_DEFAULT=1"
++ ;;
++ esac
+ tmake_file="${tmake_file} t-linux arm/t-arm"
+ case ${target} in
+ arm*-*-linux-gnueabi)
diff --git a/packages/gcc/gcc-cross_4.1.1.bb b/packages/gcc/gcc-cross_4.1.1.bb
index 4b0b5a1311..76e14ddca1 100644
--- a/packages/gcc/gcc-cross_4.1.1.bb
+++ b/packages/gcc/gcc-cross_4.1.1.bb
@@ -5,7 +5,7 @@ inherit cross
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
# NOTE: split PR. If the main .oe changes something that affects its *build*
# remember to increment this one too.
-PR = "r1"
+PR = "r2"
DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index a0dcf94be1..da4665fd88 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
@@ -10,6 +10,7 @@ inherit autotools gettext
include gcc-package.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
+ file://armeb-fix.patch;patch=1 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
file://ldflags.patch;patch=1"