aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gd
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-01-04 11:42:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-04 11:42:27 +0000
commiteef8f07cc18f2ab919f1ca4ee77a18c6f0168d5e (patch)
treef1d597a9bfa24746a55a2e062bf5508e95be283d /packages/gd
parent9e71feca7b3463548d69d4644f859c329f579a33 (diff)
downloadopenembedded-eef8f07cc18f2ab919f1ca4ee77a18c6f0168d5e.tar.gz
gd: Added by eFfeM@openembedded.org
Diffstat (limited to 'packages/gd')
-rw-r--r--packages/gd/gd_2.0.33.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/gd/gd_2.0.33.bb b/packages/gd/gd_2.0.33.bb
new file mode 100644
index 0000000000..4415c81cc9
--- /dev/null
+++ b/packages/gd/gd_2.0.33.bb
@@ -0,0 +1,28 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "libpng jpeg zlib"
+PR = "r0"
+
+SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
+S = "${WORKDIR}/gd-${PV}"
+
+inherit autotools binconfig gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-xpm"
+
+EXTRA_OEMAKE = "LDFLAGS=-L${STAGING_LIBDIR}"
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}