aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-10-14 10:37:56 +0000
committerKoen Kooi <koen@openembedded.org>2008-10-14 10:37:56 +0000
commit94d4193e5e34a1909b0c804dc64eeb67642788db (patch)
tree00a591e30a2c6d98daac4fa0a1cabe563959d72a /packages/gdal
parent45c93cb1b9dc7f51e8270f6f9acd54921f2bc052 (diff)
downloadopenembedded-94d4193e5e34a1909b0c804dc64eeb67642788db.tar.gz
gdal: update to 1.5.2
Diffstat (limited to 'packages/gdal')
-rw-r--r--packages/gdal/gdal_1.5.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gdal/gdal_1.5.2.bb b/packages/gdal/gdal_1.5.2.bb
new file mode 100644
index 0000000000..60162e15f5
--- /dev/null
+++ b/packages/gdal/gdal_1.5.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "proj-4 sqlite3 zlib jpeg libpng jasper expat"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=${STAGING_DIR_TARGET} \
+ --with-png=${STAGING_DIR_TARGET} \
+ --with-jpeg=${STAGING_DIR_TARGET} \
+ --with-jasper=${STAGING_DIR_TARGET} \
+ --with-libtiff=${STAGING_DIR_TARGET} \
+ --with-expat=${STAGING_DIR_TARGET} \
+ --with-expat-inc=${STAGING_INCDIR} \
+ --with-expat-lib=${STAGING_LIBDIR} \
+"
+
+# GDAL clutter /usr/share with files instead of using a subdir :(
+FILES_${PN} += "${datadir}"
+
+do_stage() {
+ autotools_stage_all
+}
+