aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-02-07 20:28:39 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-02-07 20:28:39 +0000
commit085c633b3088b9091308f8e09b70c4d7f0f21ae2 (patch)
tree8fea38aed241e5ed5c5237a5de19b2e93c3eaa2f /packages/gdb
parent24a15db7f3fcc37d4aab5a5f42a965c18c357ec5 (diff)
downloadopenembedded-085c633b3088b9091308f8e09b70c4d7f0f21ae2.tar.gz
gdb-cross: fix issue where patch has already been applied to 6.6
gdb-cross version 6.6 fails the patch process because the sim-install.patch tries to apply patches to Makefile-common which have already been merged into gdm mainstream. Attached is a patch for OE that seperates the two patches in sim-install.patch so that gdb-cross 6.6 only applies the first one while gdb-cross 6.3 (which also uses the sim-install.patch applies both.
Diffstat (limited to 'packages/gdb')
-rw-r--r--packages/gdb/files/sim-install-makefile-common.patch (renamed from packages/gdb/files/sim-install.patch)12
-rw-r--r--packages/gdb/files/sim-install-makefile.patch11
-rw-r--r--packages/gdb/gdb-cross_6.3.bb5
-rw-r--r--packages/gdb/gdb-cross_6.6.bb4
4 files changed, 18 insertions, 14 deletions
diff --git a/packages/gdb/files/sim-install.patch b/packages/gdb/files/sim-install-makefile-common.patch
index 3c88c4c059..24550edc6c 100644
--- a/packages/gdb/files/sim-install.patch
+++ b/packages/gdb/files/sim-install-makefile-common.patch
@@ -1,15 +1,3 @@
---- gdb-6.1/sim/common/Makefile.in~ 2004-01-15 21:25:06.000000000 +0000
-+++ gdb-6.1/sim/common/Makefile.in 2004-07-22 17:07:46.237809032 +0100
-@@ -34,7 +34,7 @@
-
- datadir = @datadir@
- mandir = @mandir@
--man1dir = $(mandir)/man1
-+man1dir = $(DESTDIR)$(mandir)/man1
- infodir = @infodir@
- includedir = @includedir@
-
-
--- gdb-6.1/sim/common/Make-common.in~sim-install.patch 2003-09-08 18:24:59.000000000 +0100
+++ gdb-6.1/sim/common/Make-common.in 2004-07-22 17:56:18.947423032 +0100
@@ -581,14 +581,14 @@
diff --git a/packages/gdb/files/sim-install-makefile.patch b/packages/gdb/files/sim-install-makefile.patch
new file mode 100644
index 0000000000..7ac67496ac
--- /dev/null
+++ b/packages/gdb/files/sim-install-makefile.patch
@@ -0,0 +1,11 @@
+--- gdb-6.6~org/sim/common/Makefile.in 2007-01-30 09:23:31.000000000 -0500
++++ gdb-6.6/sim/common/Makefile.in 2007-01-30 09:25:32.000000000 -0500
+@@ -34,7 +34,7 @@
+
+ datadir = @datadir@
+ mandir = @mandir@
+-man1dir = $(mandir)/man1
++man1dir = $(DESTDIR)$(mandir)/man1
+ infodir = @infodir@
+ includedir = @includedir@
+
diff --git a/packages/gdb/gdb-cross_6.3.bb b/packages/gdb/gdb-cross_6.3.bb
index 9cc72cca69..5dd5cf5ac5 100644
--- a/packages/gdb/gdb-cross_6.3.bb
+++ b/packages/gdb/gdb-cross_6.3.bb
@@ -5,9 +5,12 @@ DEPENDS = "ncurses-native"
inherit autotools sdk
+PR = "r1"
+
S = "${WORKDIR}/gdb-${PV}"
SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install.patch;patch=1"
+ file://sim-install-makefile.patch;patch=1 \
+ file://sim-install-makefile-common.patch;patch=1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
diff --git a/packages/gdb/gdb-cross_6.6.bb b/packages/gdb/gdb-cross_6.6.bb
index 32076b529e..03d9cda12c 100644
--- a/packages/gdb/gdb-cross_6.6.bb
+++ b/packages/gdb/gdb-cross_6.6.bb
@@ -6,9 +6,11 @@ DEPENDS = "ncurses-native"
inherit autotools sdk
+PR = "r1"
+
S = "${WORKDIR}/gdb-${PV}"
SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install.patch;patch=1"
+ file://sim-install-makefile.patch;patch=1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"