aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-07-28 07:44:57 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-07-28 07:44:57 +0000
commit7d555fe158d3b8a2a3e0ea2cea055534221d4609 (patch)
treedaac6837992affae8fd6c72e9d76bbef1f2c3976 /packages/gdb
parent40c2cb128cce5e25dfddc686d051a667ccb01eda (diff)
downloadopenembedded-7d555fe158d3b8a2a3e0ea2cea055534221d4609.tar.gz
gdb: add 6.4
- supports EABI stack - does Pawel Osiczko (still) maintain this package?
Diffstat (limited to 'packages/gdb')
-rw-r--r--packages/gdb/gdb_6.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/gdb/gdb_6.4.bb b/packages/gdb/gdb_6.4.bb
new file mode 100644
index 0000000000..9a290a3e67
--- /dev/null
+++ b/packages/gdb/gdb_6.4.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "gdb - GNU debugger"
+HOMEPAGE = "http://www.gnu.org/software/gdb/"
+LICENSE="GPL"
+SECTION = "devel"
+PRIORITY = "optional"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = "ncurses readline"
+RDEPENDS_openmn = "libthread-db1"
+
+PACKAGES =+ 'gdbserver '
+FILES_gdbserver = '${bindir}/gdbserver'
+
+inherit autotools gettext
+
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
+#FIXME: file://uclibc.patch;patch=1 \
+ file://kill_arm_map_symbols.patch;patch=1 \
+ file://gdbserver-cflags-last.diff;patch=1;pnum=0"
+
+LDFLAGS_append = " -s"
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CXX_FOR_BUILD = "${BUILD_CXX}"
+export CPP_FOR_BUILD = "${BUILD_CPP}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+export CFLAGS_append=" -L${STAGING_LIBDIR}"
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
+
+EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
+ --with-curses --disable-multilib --with-readline --disable-sim \
+ --program-prefix=''"
+
+S = "${WORKDIR}/gdb-${PV}"
+B = "${WORKDIR}/build-${TARGET_SYS}"
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
+ CPPFLAGS="" oe_runconf
+}
+
+do_install () {
+ make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
+ oe_runmake DESTDIR='${D}' install
+ install -d ${D}${bindir}
+ install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
+}