aboutsummaryrefslogtreecommitdiffstats
path: root/packages/geda
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-12-11 12:26:28 +0000
committerutx@penguin.cz <utx@penguin.cz>2008-12-11 12:27:49 +0000
commit976dd9b03fdb8590bb583744163a32106b956037 (patch)
tree7ad90f9f963962453dc4160b69cedab9faaf0310 /packages/geda
parent9b210063ed0457faadc3f6c9fc1dc482721f48c6 (diff)
downloadopenembedded-976dd9b03fdb8590bb583744163a32106b956037.tar.gz
geda-xgsch2pcb: New package.
Diffstat (limited to 'packages/geda')
-rw-r--r--packages/geda/files/skip-python-checks.patch42
-rw-r--r--packages/geda/geda-xgsch2pcb_0.1.2.bb19
2 files changed, 61 insertions, 0 deletions
diff --git a/packages/geda/files/skip-python-checks.patch b/packages/geda/files/skip-python-checks.patch
new file mode 100644
index 0000000000..8043ff340c
--- /dev/null
+++ b/packages/geda/files/skip-python-checks.patch
@@ -0,0 +1,42 @@
+Index: geda-xgsch2pcb-0.1.2/configure.ac
+===================================================================
+--- geda-xgsch2pcb-0.1.2.orig/configure.ac 2008-01-11 05:16:07.000000000 +0000
++++ geda-xgsch2pcb-0.1.2/configure.ac 2008-12-09 15:03:31.000000000 +0000
+@@ -39,15 +39,7 @@
+
+ AC_DEFUN([AC_PYTHON_MODULE],[
+ AC_MSG_CHECKING([for python module $1])
+- $PYTHON -c "import $1" > /dev/null 2>&1
+- if test $? -eq 0; then
+- AC_MSG_RESULT(yes)
+- else
+- AC_MSG_RESULT(no)
+- if test -n "$2"; then
+- AC_MSG_ERROR([python module $1 is required])
+- fi
+- fi
++ AC_MSG_RESULT(skipping)
+ ])
+
+
+@@ -135,20 +127,6 @@
+ AC_MSG_CHECKING(for gtk+ >= $GTK_WANTVERSION)
+ cat > conftest.py <<[EOF
+ import sys
+-try:
+- import gtk
+- ver = gtk.gtk_version
+- sys.stdout.write(".".join(map(str, ver)))
+- if len(sys.argv) > 1:
+- wantver = sys.argv[1].split(".")
+- wantver = map(int, wantver)
+- for i in range(len(wantver)):
+- if i > len(ver):
+- break
+- if wantver[i] > ver[i]:
+- sys.exit(1)
+-except:
+- sys.exit(1)
+ sys.exit(0)
+ EOF]
+
diff --git a/packages/geda/geda-xgsch2pcb_0.1.2.bb b/packages/geda/geda-xgsch2pcb_0.1.2.bb
new file mode 100644
index 0000000000..dfa500e165
--- /dev/null
+++ b/packages/geda/geda-xgsch2pcb_0.1.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Graphical front-end for the gschem -> pcb workflow"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/icons"
+
+DEPENDS = "python-native"
+# python-codecs for gettext.py
+RDEPENDS = "geda-utils python-codecs python-dbus python-pygtk python-subprocess"
+
+SRC_URI = "http://geda.seul.org/dist/${P}.tar.gz \
+ file://skip-python-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-update-desktop-database"
+
+do_configure_prepend() {
+ sed -i -e s:\\\$\(PYTHON\):${bindir}/python:g Makefile.am
+}