aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gettext
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2008-10-17 18:13:39 +0200
committerwoglinde <heinold@inf.fu-berlin.de>2008-10-17 18:13:39 +0200
commit3e8df80fdfb2da7672e1a771b70ccd30b119b968 (patch)
tree2f6a74a188ae3ac4f738bf8bec12959eed7d39e7 /packages/gettext
parentc6535102cb928756eb419b007e9bd14caf6cf1c8 (diff)
downloadopenembedded-3e8df80fdfb2da7672e1a771b70ccd30b119b968.tar.gz
gettext: add patch open() mode from ubuntu
* add use_open_properly.patch from ubuntu gettext_0.17-3ubuntu2.diff * bump PR on native and target
Diffstat (limited to 'packages/gettext')
-rw-r--r--packages/gettext/gettext-0.17/use_open_properly.patch15
-rw-r--r--packages/gettext/gettext-native_0.17.bb2
-rw-r--r--packages/gettext/gettext_0.17.bb3
3 files changed, 18 insertions, 2 deletions
diff --git a/packages/gettext/gettext-0.17/use_open_properly.patch b/packages/gettext/gettext-0.17/use_open_properly.patch
new file mode 100644
index 0000000000..111714b543
--- /dev/null
+++ b/packages/gettext/gettext-0.17/use_open_properly.patch
@@ -0,0 +1,15 @@
+Index: gettext-0.17/gettext-tools/src/write-catalog.c
+===================================================================
+--- gettext-0.17.orig/gettext-tools/src/write-catalog.c 2008-10-16 15:18:16.000000000 +0200
++++ gettext-0.17/gettext-tools/src/write-catalog.c 2008-10-16 18:17:13.000000000 +0200
+@@ -220,7 +220,9 @@
+ /* Open the output file. */
+ if (!to_stdout)
+ {
+- fd = open (filename, O_WRONLY | O_CREAT);
++ fd = open (filename, O_WRONLY | O_CREAT,
++ /* 0666 in portable POSIX notation: */
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if (fd < 0)
+ {
+ const char *errno_description = strerror (errno);
diff --git a/packages/gettext/gettext-native_0.17.bb b/packages/gettext/gettext-native_0.17.bb
index 9f6cb861bd..c07302bc2b 100644
--- a/packages/gettext/gettext-native_0.17.bb
+++ b/packages/gettext/gettext-native_0.17.bb
@@ -1,5 +1,5 @@
require gettext_${PV}.bb
-FILE_PR = "r2"
+FILE_PR = "r3"
DEPENDS = ""
PROVIDES = ""
diff --git a/packages/gettext/gettext_0.17.bb b/packages/gettext/gettext_0.17.bb
index 13ac5b9373..fe48080085 100644
--- a/packages/gettext/gettext_0.17.bb
+++ b/packages/gettext/gettext_0.17.bb
@@ -2,13 +2,14 @@ DESCRIPTION = "The GNU internationalization library."
HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
SECTION = "libs"
LICENSE = "GPL"
-FILE_PR = "r1"
+FILE_PR = "r2"
DEPENDS = "gettext-native virtual/libiconv ncurses expat"
PROVIDES = "virtual/libintl"
SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
file://autotools.patch;patch=1 \
file://wchar-uclibc.patch;patch=1 \
+ file://use_open_properly.patch;patch=1 \
"
SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"