aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gimp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-26 10:01:21 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-26 10:01:21 +0000
commit2dc25ce7caf72b58900b88870e7e022e569f7a61 (patch)
treedbadb60be5f4a5aa95cd3a2a911ad3cf5f8aa3f4 /packages/gimp
parent3cdc3b52b167778be7f2c45b1a885f0af7864f97 (diff)
downloadopenembedded-2dc25ce7caf72b58900b88870e7e022e569f7a61.tar.gz
gimp: add 2.3.19, unify old recipes
Diffstat (limited to 'packages/gimp')
-rw-r--r--packages/gimp/gimp.inc38
-rw-r--r--packages/gimp/gimp_2.2.10.bb19
-rw-r--r--packages/gimp/gimp_2.3.10.bb36
-rw-r--r--packages/gimp/gimp_2.3.19.bb2
-rw-r--r--packages/gimp/gimp_2.3.7.bb20
-rw-r--r--packages/gimp/gimp_2.3.8.bb22
6 files changed, 45 insertions, 92 deletions
diff --git a/packages/gimp/gimp.inc b/packages/gimp/gimp.inc
new file mode 100644
index 0000000000..7a75f7d619
--- /dev/null
+++ b/packages/gimp/gimp.inc
@@ -0,0 +1,38 @@
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+SECTION = "x11/graphics"
+LICENSE = "GPL"
+
+DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
+ file://configure-libwmf.patch;patch=1"
+
+inherit autotools pkgconfig
+
+FILES_gimp-dbg =+ "${libdir}/gimp/2.0/modules/.debug \
+ ${libdir}/gimp/2.0/plug-ins/.debug"
+
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF = " --disable-gtktest \
+ --disable-print \
+ --disable-python \
+ --enable-mp \
+ --without-libwmf"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+}
+
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/icons \
+ ${datadir}/mime-info \
+ ${datadir}/application-registry "
+
+FILES_${PN}-dbg += "${libdir}/gimp/2.0/plug-ins/.debug \
+ ${libdir}/gimp/2.0/modules/.debug"
+
diff --git a/packages/gimp/gimp_2.2.10.bb b/packages/gimp/gimp_2.2.10.bb
index 10242e23df..3719e2d5e5 100644
--- a/packages/gimp/gimp_2.2.10.bb
+++ b/packages/gimp/gimp_2.2.10.bb
@@ -1,21 +1,4 @@
-DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
-HOMEPAGE = "http://www.gimp.org"
-SECTION = "x11/graphics"
-LICENSE = "GPL"
+require gimp.inc
PR = "r1"
-SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.2/gimp-${PV}.tar.bz2"
-
-DEPENDS = "gtk+ jpeg libpng libexif"
-
-inherit autotools pkgconfig
-#Don't laugh, this just builds a threaded gimp
-EXTRA_OECONF = " --disable-gtktest \
- --without-libtiff \
- --disable-print \
- --enable-mp"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
-}
diff --git a/packages/gimp/gimp_2.3.10.bb b/packages/gimp/gimp_2.3.10.bb
index f43140eca4..b06687c06d 100644
--- a/packages/gimp/gimp_2.3.10.bb
+++ b/packages/gimp/gimp_2.3.10.bb
@@ -1,35 +1,3 @@
-DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
-HOMEPAGE = "http://www.gimp.org"
-SECTION = "x11/graphics"
-LICENSE = "GPL"
-PR = "r2"
-
-DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
-
-SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
- file://configure-libwmf.patch;patch=1"
-
-inherit autotools pkgconfig
-
-FILES_gimp-dbg =+ "${libdir}/gimp/2.0/modules/.debug \
- ${libdir}/gimp/2.0/plug-ins/.debug"
-
-#Don't laugh, this just builds a threaded gimp
-EXTRA_OECONF = " --disable-gtktest \
- --disable-print \
- --disable-python \
- --enable-mp \
- --without-libwmf"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
-}
-
-
-FILES_${PN} += "${datadir}/icons \
- ${datadir}/mime-info \
- ${datadir}/application-registry "
-
-FILES_${PN}-dbg += "${libdir}/gimp/2.0/plug-ins/.debug \
- ${libdir}/gimp/2.0/modules/.debug"
+require gimp.inc
+PR = "r3"
diff --git a/packages/gimp/gimp_2.3.19.bb b/packages/gimp/gimp_2.3.19.bb
new file mode 100644
index 0000000000..64d8d30e3a
--- /dev/null
+++ b/packages/gimp/gimp_2.3.19.bb
@@ -0,0 +1,2 @@
+require gimp.inc
+
diff --git a/packages/gimp/gimp_2.3.7.bb b/packages/gimp/gimp_2.3.7.bb
index 59bc63d5ae..7e72e74695 100644
--- a/packages/gimp/gimp_2.3.7.bb
+++ b/packages/gimp/gimp_2.3.7.bb
@@ -1,20 +1,2 @@
-DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
-HOMEPAGE = "http://www.gimp.org"
-SECTION = "x11/graphics"
-LICENSE = "GPL"
+require gimp.inc
PR = "r1"
-
-SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2"
-
-DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
-
-inherit autotools pkgconfig
-#Don't laugh, this just builds a threaded gimp
-EXTRA_OECONF = " --disable-gtktest \
- --disable-print \
- --disable-python \
- --enable-mp"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
-}
diff --git a/packages/gimp/gimp_2.3.8.bb b/packages/gimp/gimp_2.3.8.bb
index 03d88ed522..7e72e74695 100644
--- a/packages/gimp/gimp_2.3.8.bb
+++ b/packages/gimp/gimp_2.3.8.bb
@@ -1,22 +1,2 @@
-DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
-HOMEPAGE = "http://www.gimp.org"
-SECTION = "x11/graphics"
-LICENSE = "GPL"
+require gimp.inc
PR = "r1"
-
-SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
- file://configure-libwmf.patch;patch=1"
-
-DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
-
-inherit autotools pkgconfig
-#Don't laugh, this just builds a threaded gimp
-EXTRA_OECONF = " --disable-gtktest \
- --disable-print \
- --disable-python \
- --enable-mp \
- --without-libwmf"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
-}