aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gimp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-09-07 14:27:25 +0000
committerKoen Kooi <koen@openembedded.org>2006-09-07 14:27:25 +0000
commit6f5ad23ff4f0e08383a18355330ceb7b2f79f4a6 (patch)
treeac65d774f5b867e354cd7b92b8d6044709945532 /packages/gimp
parent3428d0098febbb8553df208dafffb8400db9c566 (diff)
downloadopenembedded-6f5ad23ff4f0e08383a18355330ceb7b2f79f4a6.tar.gz
gimp: add 2.3.10
Diffstat (limited to 'packages/gimp')
-rw-r--r--packages/gimp/gimp_2.3.10.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/packages/gimp/gimp_2.3.10.bb b/packages/gimp/gimp_2.3.10.bb
index eb760ec9d8..f28ff7d52d 100644
--- a/packages/gimp/gimp_2.3.10.bb
+++ b/packages/gimp/gimp_2.3.10.bb
@@ -1,23 +1,23 @@
-DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
-HOMEPAGE = "http://www.gimp.org"
-LICENSE = "GPL"
-MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
+LICENSE = "GPL"
-SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
- file://configure-libwmf.patch;patch=1"
-
-DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
+DEPENDS = "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
-DEFAULT_PREFERENCE = "-1"
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
+ file://configure-libwmf.patch;patch=1"
inherit autotools pkgconfig
+
#Don't laugh, this just builds a threaded gimp
-EXTRA_OECONF = " --disable-gtktest \
- --disable-print \
- --disable-python \
- --enable-mp \
- --without-libwmf"
+EXTRA_OECONF = " --disable-gtktest \
+ --disable-print \
+ --disable-python \
+ --enable-mp \
+ --without-libwmf"
do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
}
+