aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git/files
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-13 14:34:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-13 14:34:15 +0000
commitb592ec4ea4cb7b57edc8b9f2953a336209fde60c (patch)
tree22204fa08331dfab9dab31213db92c509c72976a /packages/git/files
parentaeb5e8d2e0ca39cd27c88265fbb5edea501d1ec9 (diff)
downloadopenembedded-b592ec4ea4cb7b57edc8b9f2953a336209fde60c.tar.gz
git: Add git and git-native packages. git-native may need some addition dependencies (curl-native, openssl-native) - I'm not sure what the policy is on this. Adding them should be straight forward enough though.
Diffstat (limited to 'packages/git/files')
-rw-r--r--packages/git/files/.mtn2git_empty0
-rw-r--r--packages/git/files/Makefile.patch13
2 files changed, 13 insertions, 0 deletions
diff --git a/packages/git/files/.mtn2git_empty b/packages/git/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/git/files/.mtn2git_empty
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
new file mode 100644
index 0000000000..0a82649db9
--- /dev/null
+++ b/packages/git/files/Makefile.patch
@@ -0,0 +1,13 @@
+Index: git-snapshot-20050912/Makefile
+===================================================================
+--- git-snapshot-20050912.orig/Makefile 2005-09-11 03:46:53.000000000 +0100
++++ git-snapshot-20050912/Makefile 2005-09-12 12:18:38.000000000 +0100
+@@ -239,7 +240,7 @@
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ git-%: %.o $(LIB_FILE)
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+
+ git-mailinfo : SIMPLE_LIB += $(LIB_4_ICONV)
+ $(SIMPLE_PROGRAMS) : $(LIB_FILE)