aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2008-11-18 16:08:52 -0500
committerDenys Dmytriyenko <denis@denix.org>2008-11-18 16:08:52 -0500
commit46e30ed6ebb1a872f919363c6ff047344049079c (patch)
tree90f1e415762cf9aab12b14cc10de664d661304f6 /packages/git
parent4728c7ef0b0742deecc40a8a1baaf2a0e3c996da (diff)
downloadopenembedded-46e30ed6ebb1a872f919363c6ff047344049079c.tar.gz
git: fix configure failing on snprintf-returns-bogus check when cross-compiling
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/files/snprintf-returns-bogus.patch12
-rw-r--r--packages/git/git_1.6.0.4.bb7
2 files changed, 18 insertions, 1 deletions
diff --git a/packages/git/files/snprintf-returns-bogus.patch b/packages/git/files/snprintf-returns-bogus.patch
new file mode 100644
index 0000000000..568bb1f56b
--- /dev/null
+++ b/packages/git/files/snprintf-returns-bogus.patch
@@ -0,0 +1,12 @@
+--- git-1.6.0.4-orig/configure.ac 2008-11-18 15:28:03.000000000 -0500
++++ git-1.6.0.4/configure.ac 2008-11-18 15:30:45.000000000 -0500
+@@ -373,7 +373,8 @@
+ if (snprintf(buf, 3, "%s", "12345") != 5
+ || strcmp(buf, "12")) return 1]])],
+ [ac_cv_snprintf_returns_bogus=no],
+- [ac_cv_snprintf_returns_bogus=yes])
++ [ac_cv_snprintf_returns_bogus=yes],
++ [ac_cv_snprintf_returns_bogus=no])
+ ])
+ if test $ac_cv_snprintf_returns_bogus = yes; then
+ SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
diff --git a/packages/git/git_1.6.0.4.bb b/packages/git/git_1.6.0.4.bb
index e06a4b2a8a..e839ab960a 100644
--- a/packages/git/git_1.6.0.4.bb
+++ b/packages/git/git_1.6.0.4.bb
@@ -1,4 +1,9 @@
require git.inc
+
+SRC_URI += "file://snprintf-returns-bogus.patch;patch=1"
+
DEPENDS = "openssl curl zlib expat"
RDEPENDS = "perl perl-module-file-path cpio findutils sed"
-PR = "r3"
+PR = "r4"
+
+FILES_${PN}-dbg += "${libexecdir}/git-core/.debug"