aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-13 14:34:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-13 14:34:15 +0000
commitb592ec4ea4cb7b57edc8b9f2953a336209fde60c (patch)
tree22204fa08331dfab9dab31213db92c509c72976a /packages/git
parentaeb5e8d2e0ca39cd27c88265fbb5edea501d1ec9 (diff)
downloadopenembedded-b592ec4ea4cb7b57edc8b9f2953a336209fde60c.tar.gz
git: Add git and git-native packages. git-native may need some addition dependencies (curl-native, openssl-native) - I'm not sure what the policy is on this. Adding them should be straight forward enough though.
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/.mtn2git_empty0
-rw-r--r--packages/git/files/.mtn2git_empty0
-rw-r--r--packages/git/files/Makefile.patch13
-rw-r--r--packages/git/git-native.bb8
-rw-r--r--packages/git/git.bb21
5 files changed, 42 insertions, 0 deletions
diff --git a/packages/git/.mtn2git_empty b/packages/git/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/git/.mtn2git_empty
diff --git a/packages/git/files/.mtn2git_empty b/packages/git/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/git/files/.mtn2git_empty
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
new file mode 100644
index 0000000000..0a82649db9
--- /dev/null
+++ b/packages/git/files/Makefile.patch
@@ -0,0 +1,13 @@
+Index: git-snapshot-20050912/Makefile
+===================================================================
+--- git-snapshot-20050912.orig/Makefile 2005-09-11 03:46:53.000000000 +0100
++++ git-snapshot-20050912/Makefile 2005-09-12 12:18:38.000000000 +0100
+@@ -239,7 +240,7 @@
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ git-%: %.o $(LIB_FILE)
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+
+ git-mailinfo : SIMPLE_LIB += $(LIB_4_ICONV)
+ $(SIMPLE_PROGRAMS) : $(LIB_FILE)
diff --git a/packages/git/git-native.bb b/packages/git/git-native.bb
new file mode 100644
index 0000000000..1bd495f085
--- /dev/null
+++ b/packages/git/git-native.bb
@@ -0,0 +1,8 @@
+include git.bb
+inherit native
+
+do_stage () {
+ oe_runmake install bindir=${STAGING_BINDIR} \
+ template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
+ GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
+}
diff --git a/packages/git/git.bb b/packages/git/git.bb
new file mode 100644
index 0000000000..3a1228d621
--- /dev/null
+++ b/packages/git/git.bb
@@ -0,0 +1,21 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+DEPENDS = "openssl curl"
+MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
+
+PKGDATE = "${@time.strftime('%Y-%m-%d',time.gmtime())}"
+
+SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/git-snapshot-${DATE}"
+
+FILES_${PN} += "${datadir}/git-core"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+